Plugins · leaky-paywall · data as of 2026-11-04
Is Leaky Paywall safe? Known vulnerabilities and latest version
- Status
- Closed 2026-11-03
- Known issues on record
- 5
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate leaky-paywall && wp plugin delete leaky-paywall
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
medium 5.3 CVE-2025-66124 · published 2025-12-16
Missing authorization check in Leaky Paywall (4.22.6 and older)
- Affected
- 4.22.6 and older
- Fixed in
- 5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in ZEEN101 Leaky Paywall leaky-paywall allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Leaky Paywall: from n/a through <= 4.22.6.
medium 6.5 CVE-2025-31083 · published 2025-03-28
Stored cross-site scripting (XSS) in Leaky Paywall (4.21.7 and older)
- Affected
- 4.21.7 and older
- Fixed in
- 4.21.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ZEEN101 Leaky Paywall leaky-paywall allows Stored XSS.This issue affects Leaky Paywall: from n/a through <= 4.21.7.
medium 4.3 CVE-2024-37540 · published 2025-01-02
Cross-site request forgery (CSRF) in Leaky Paywall (4.21.2 and older)
- Affected
- 4.21.2 and older
- Fixed in
- 4.21.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in ZEEN101 Leaky Paywall leaky-paywall allows Cross Site Request Forgery.This issue affects Leaky Paywall: from n/a through <= 4.21.2.
high 7.5 CVE-2024-33594 · published 2024-04-29
Missing authorization check in Leaky Paywall (4.20.8 and older)
- Affected
- 4.20.8 and older
- Fixed in
- 4.20.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Leaky Paywall.This issue affects Leaky Paywall: from n/a through 4.20.8.
medium 4.8 CVE-2021-39357 · published 2021-10-21
Stored cross-site scripting (XSS) in Leaky Paywall (4.16.5 to 4.16.5)
- Affected
- 4.16.5 to 4.16.5
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Leaky Paywall WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via the ~/class.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 4.16.5. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.
NVD CVE-2021-39357Code change (fix)github.comWordfence advisory
Recent activity
- 2026-11-03 — closed on wordpress.org.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-66124), fixed in 5.0.
- 2025-03-28 — Stored cross-site scripting (XSS) disclosed (CVE-2025-31083), fixed in 4.21.8.
- 2025-01-02 — Cross-site request forgery (CSRF) disclosed (CVE-2024-37540), fixed in 4.21.3.
Get an email when Leaky Paywall has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Leaky Paywall (leaky-paywall) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/leaky-paywall (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/leaky-paywall"><img src="https://laskyr.com/plugins/leaky-paywall/badge.svg" alt="Leaky Paywall vulnerability status"></a>