Plugins · leaflet-map · data as of 2026-11-04
Is Leaflet Map safe? Known vulnerabilities and latest version
- Latest version
- 3.4.7
- Last updated
- 2026-08-22
- Active installs
- 30,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Interactive maps and markers on your posts and pages with simple shortcodes. — by bozdoz
What to do
- Update to the latest version (3.4.7). Anything older than 3.4.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get leaflet-map --field=version shows what you run; wp plugin update leaflet-map updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-39646 · published 2026-04-08
Stored cross-site scripting (XSS) in Leaflet Map (3.4.4 and older)
- Affected
- 3.4.4 and older
- Fixed in
- 3.4.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bozdoz Leaflet Map leaflet-map allows Stored XSS.This issue affects Leaflet Map: from n/a through <= 3.4.4.
medium 5.4 CVE-2023-5050 · published 2023-10-20
Stored cross-site scripting (XSS) in Leaflet Map (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Leaflet Map plugin for WordPress is vulnerable to Stored Cross-Site Scripting via shortcodes in versions up to, and including, 3.3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with contributor level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-5050Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2021-24467 · published 2021-08-09
Cross-site request forgery (CSRF) in Leaflet Map (older than 3.0.0)
- Affected
- older than 3.0.0
- Fixed in
- 3.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Leaflet Map WordPress plugin before 3.0.0 does not verify the CSRF nonce when saving its settings, which allows attackers to make a logged in admin update the settings via a Cross-Site Request Forgery attack. This could lead to Cross-Site Scripting issues by either changing the URL of the JavaScript library being used, or using malicious attributions which will be executed in all page with an embed map from the plugin
medium 5.4 CVE-2021-24468 · published 2021-08-02
Stored cross-site scripting (XSS) in Leaflet Map (older than 3.0.0)
- Affected
- older than 3.0.0
- Fixed in
- 3.0.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Leaflet Map WordPress plugin before 3.0.0 does not escape some shortcode attributes before they are used in JavaScript code or HTML, which could allow users with a role as low as Contributors to exploit stored XSS issues
Recent activity
- 2026-08-22 — latest release on wordpress.org (3.4.7).
- 2026-04-08 — Stored cross-site scripting (XSS) disclosed (CVE-2026-39646), fixed in 3.4.5.
- 2023-10-20 — Stored cross-site scripting (XSS) disclosed (CVE-2023-5050), fixed in 3.3.1.
- 2021-08-09 — Cross-site request forgery (CSRF) disclosed (CVE-2021-24467), fixed in 3.0.0.
Get an email when Leaflet Map has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Leaflet Map (leaflet-map) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/leaflet-map (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/leaflet-map"><img src="https://laskyr.com/plugins/leaflet-map/badge.svg" alt="Leaflet Map vulnerability status"></a>