Skip to content
Laskyr

Plugins · leadin · data as of 2026-11-04

Is HubSpot All-In-One Marketing safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (11.3.75)

As of 2026-11-04. 4 issues are on record for older versions; version 11.3.64 or newer fixes all of them that state a fix.

Latest version
11.3.75
Last updated
2026-09-16
Active installs
200,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

The CRM, Sales, and Marketing WordPress plugin to grow your business better. Capture and engage web visitors with free live chat, forms, CRM, email ma … — by HubSpot

What to do

  1. Update to the latest version (11.3.75). Anything older than 11.3.64 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get leadin --field=version shows what you run; wp plugin update leadin updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-9656 · published 2026-07-17

Information disclosure in HubSpot All-In-One Marketing (11.3.62 and older)

Affected
11.3.62 and older
Fixed in
11.3.64 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HubSpot All-In-One Marketing – Forms, Popups, Live Chat plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.3.62 via the wp_localize_script() / window.leadinConfig JavaScript object. This makes it possible for authenticated attackers, with contributor-level access and above, to extract the site's plaintext HubSpot OAuth refresh token exposed via the window.leadinConfig JavaScript object, which can then be used to access or modify data in the connected HubSpot tenant. Although the refresh token is stored at rest with AES-256-CTR encryption, decryption occurs server-side before the plaintext value is passed to wp_localize_script(), rendering the at-rest encryption ineffective against this exposure path.

NVD CVE-2026-9656Wordfence advisoryCode change (fix)Plugin source

high 7.4 CVE-2026-57736 · published 2026-07-01

Information disclosure in HubSpot All-In-One Marketing (11.3.51 and older)

Affected
11.3.51 and older
Fixed in
11.3.56 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in HubSpot allows Retrieve Embedded Sensitive Data. This issue affects HubSpot: from n/a through 11.3.51.

NVD CVE-2026-57736Patchstack advisory

medium 4.3 CVE-2025-11762 · published 2026-04-24

Information disclosure in HubSpot All-In-One Marketing (11.3.32 and older)

Affected
11.3.32 and older
Fixed in
11.3.33 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The HubSpot All-In-One Marketing - Forms, Popups, Live Chat plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.3.32 via the leadin/public/admin/class-adminconstants.php file. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract a list of all installed plugins and their versions which can be leveraged for reconnaissance and further attacks.

NVD CVE-2025-11762Wordfence advisoryresearch.cleantalk.orgPlugin source

medium 5.4 CVE-2024-5879 · published 2024-08-30

Stored cross-site scripting (XSS) in HubSpot All-In-One Marketing (11.1.22 and older)

Affected
11.1.22 and older
Fixed in
11.1.34 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'url' attribute of the HubSpot Meeting Widget in all versions up to, and including, 11.1.22 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5879Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
HubSpot All-In-One Marketing vulnerability status badge
<a href="https://laskyr.com/plugins/leadin"><img src="https://laskyr.com/plugins/leadin/badge.svg" alt="HubSpot All-In-One Marketing vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit