Skip to content
Laskyr

Plugins · leadconnector · data as of 2026-11-04

Is LeadConnector safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.6)

As of 2026-11-04. 6 issues are on record for older versions; version 4.0.6 or newer fixes all of them that state a fix.

Latest version
4.0.6
Last updated
2026-08-24
Active installs
20,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Connect WordPress to LeadConnector for chat widgets, funnels, forms, calendars, reviews, custom values, and CRM tools. — by LeadConnector

What to do

  1. Update to the latest version (4.0.6). Anything older than 4.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get leadconnector --field=version shows what you run; wp plugin update leadconnector updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-81298 · published 2026-08-31

Cross-site scripting (XSS) in LeadConnector (4.0.5 and older)

Affected
4.0.5 and older
Fixed in
4.0.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in LeadConnector <= 4.0.5 versions.

NVD CVE-2026-81298Patchstack advisory

medium 5.3 CVE-2026-1890 · published 2026-03-26

Security issue in LeadConnector (older than 3.0.22)

Affected
older than 3.0.22
Fixed in
3.0.22
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The LeadConnector WordPress plugin before 3.0.22 does not have authorization in a REST route, allowing unauthenticated users to call it and overwrite existing data

NVD CVE-2026-1890WPScan advisory

medium 5.3 CVE-2026-25441 · published 2026-02-19

Missing authorization check in LeadConnector (3.0.21 and older)

Affected
3.0.21 and older
Fixed in
3.0.22
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in varunvairavanlc LeadConnector leadconnector allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects LeadConnector: from n/a through <= 3.0.21.

NVD CVE-2026-25441Patchstack advisory

medium 6.5 CVE-2025-30893 · published 2025-03-27

Cross-site scripting (XSS) in LeadConnector (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LeadConnector LeadConnector leadconnector allows DOM-Based XSS.This issue affects LeadConnector: from n/a through <= 3.0.2.

NVD CVE-2025-30893Patchstack advisory

high 8.6 CVE-2024-34378 · published 2024-05-06

Missing authorization check in LeadConnector (1.7 and older)

Affected
1.7 and older
Fixed in
1.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in LeadConnector.This issue affects LeadConnector: from n/a through 1.7.

NVD CVE-2024-34378Patchstack advisory

medium 6.5 CVE-2024-1371 · published 2024-04-30

Missing authorization check in LeadConnector (1.7 and older)

Affected
1.7 and older
Fixed in
1.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LeadConnector plugin for WordPress is vulnerable to unauthorized modification & loss of data due to a missing capability check on the lc_public_api_proxy() function in all versions up to, and including, 1.7. This makes it possible for unauthenticated attackers to delete arbitrary posts. CVE-2024-34378 is likely a duplicate of this issue.

NVD CVE-2024-1371Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LeadConnector vulnerability status badge
<a href="https://laskyr.com/plugins/leadconnector"><img src="https://laskyr.com/plugins/leadconnector/badge.svg" alt="LeadConnector vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit