Skip to content
Laskyr

Plugins · lazytasks-project-task-management · data as of 2026-11-04

Is LazyTasks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.47)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.01 or newer fixes all of them that state a fix.

Latest version
1.8.47
Last updated
2026-10-20
Active installs
90+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Free project and task management for WordPress: Kanban, Gantt, calendar, reports and roles, plus native iOS and Android apps. — by LazyCoders LLC

What to do

  1. Update to the latest version (1.8.47). Anything older than 1.3.01 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get lazytasks-project-task-management --field=version shows what you run; wp plugin update lazytasks-project-task-management updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2025-68869 · published 2026-01-22

Privilege escalation in LazyTasks (1.2.37 and older)

Affected
1.2.37 and older
Fixed in
1.3.01
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in LazyCoders LLC LazyTasks lazytasks-project-task-management allows Privilege Escalation.This issue affects LazyTasks: from n/a through <= 1.2.37.

NVD CVE-2025-68869Patchstack advisory

critical 9.8 CVE-2025-12963 · published 2025-12-12

Privilege escalation in LazyTasks (1.2.29 and older)

Affected
1.2.29 and older
Fixed in
1.2.35 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LazyTasks – Project & Task Management with Collaboration, Kanban and Gantt Chart plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.2.29. This is due to the plugin not properly validating a user's identity via the 'wp-json/lazytasks/api/v1/user/role/edit/' REST API endpoint prior to updating their details like email address. This makes it possible for unauthenticated attackers to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account. It is also possible for attackers to abuse this endpoint to grant users with access to additional roles within the plugin

NVD CVE-2025-12963Wordfence advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LazyTasks vulnerability status badge
<a href="https://laskyr.com/plugins/lazytasks-project-task-management"><img src="https://laskyr.com/plugins/lazytasks-project-task-management/badge.svg" alt="LazyTasks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit