Plugins · lazy-load-for-videos · data as of 2026-11-04
Is Lazy Load for Videos safe? Known vulnerabilities and latest version
- Latest version
- 2.18.12
- Last updated
- 2026-10-25
- Active installs
- 9,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Boost page speed by replacing embedded YouTube and Vimeo videos with a clickable preview image. Video scripts only load on click. — by kevinweber
What to do
- Update to the latest version (2.18.12). Anything older than 2.18.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get lazy-load-for-videos --field=version shows what you run; wp plugin update lazy-load-for-videos updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-115951 · published 2026-10-26
Stored cross-site scripting (XSS) in Lazy Load for Videos (2.18.11 and older)
- Affected
- 2.18.11 and older
- Fixed in
- 2.18.12
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kevin Weber Lazy Load for Videos lazy-load-for-videos allows Stored XSS.This issue affects Lazy Load for Videos: from n/a through 2.18.11.
medium 6.4 CVE-2025-7732 · published 2025-08-27
Stored cross-site scripting (XSS) in Lazy Load for Videos (2.18.7 and older)
- Affected
- 2.18.7 and older
- Fixed in
- 2.18.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Lazy Load for Videos plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its lazy‑loading handlers in all versions up to, and including, 2.18.7 due to insufficient input sanitization and output escaping. The plugin’s JavaScript registration handlers read the client‑supplied 'data-video-title' and 'href' attributes, decode HTML entities by default, and pass them directly into DOM sinks without any escaping or validation. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-7732Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 8.8 CVE-2023-45656 · published 2023-10-16
Cross-site request forgery (CSRF) in Lazy Load for Videos (2.18.2 and older)
- Affected
- 2.18.2 and older
- Fixed in
- 2.18.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Kevin Weber Lazy Load for Videos plugin <= 2.18.2 versions.
Recent activity
- 2026-10-25 — latest release on wordpress.org (2.18.12).
- 2026-10-26 — Stored cross-site scripting (XSS) disclosed (CVE-2026-115951), fixed in 2.18.12.
- 2025-08-27 — Stored cross-site scripting (XSS) disclosed (CVE-2025-7732), fixed in 2.18.8.
- 2023-10-16 — Cross-site request forgery (CSRF) disclosed (CVE-2023-45656), fixed in 2.18.3.
Get an email when Lazy Load for Videos has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Lazy Load for Videos (lazy-load-for-videos) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/lazy-load-for-videos (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/lazy-load-for-videos"><img src="https://laskyr.com/plugins/lazy-load-for-videos/badge.svg" alt="Lazy Load for Videos vulnerability status"></a>