Plugins · layouts-for-wpbakery · data as of 2026-11-04
Is Layouts for WPBakery safe? Known vulnerabilities and latest version
- Latest version
- 2.0
- Last updated
- 2026-09-28
- Active installs
- 3,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Layouts for WPBakery is a beautifully designed free layout for famous WordPress WPBakery page builders. — by Techeshta
What to do
- Update to the latest version (2.0). Anything older than 1.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get layouts-for-wpbakery --field=version shows what you run; wp plugin update layouts-for-wpbakery updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-7726 · published 2026-08-05
Missing authorization check in Layouts for WPBakery (1.1.3 and older)
- Affected
- 1.1.3 and older
- Fixed in
- 1.1.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Layouts for WPBakery plugin for WordPress is vulnerable to unauthorized actions due to a missing capability check on the `Layouts_WPB_Remote::template_sync()` callback registered via `wp_ajax_nopriv_handle_sync` in all versions up to, and including, 1.1.3. This makes it possible for unauthenticated attackers to force the WordPress server to issue outbound HTTP requests to the plugin vendor's external API (`https://www.layoutsforwpbakery.com/wp-json/layoutsforwpbakery/v1/{templates,categories}`) and to write the JSON-decoded responses verbatim into the site's `wp_options` table via `set_transient()` — at any rate the attacker chooses, with no nonce verification, capability check, or rate limiting.
NVD CVE-2026-7726Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-09-28 — latest release on wordpress.org (2.0).
- 2026-08-05 — Missing authorization check disclosed (CVE-2026-7726), fixed in 1.1.4.
Get an email when Layouts for WPBakery has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Layouts for WPBakery (layouts-for-wpbakery) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Techeshta (2 tracked)
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/layouts-for-wpbakery (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/layouts-for-wpbakery"><img src="https://laskyr.com/plugins/layouts-for-wpbakery/badge.svg" alt="Layouts for WPBakery vulnerability status"></a>