Plugins · latest-post-shortcode · data as of 2026-11-04
Is Latest Post Shortcode safe? Known vulnerabilities and latest version
- Latest version
- 14.2.3
- Last updated
- 2026-04-10
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.3.5+
The "Latest Post Shortcode" allows you to create a dynamic content selection from your posts by combining, limiting, and filtering what you need. — by Iulia Cazan
What to do
- Update to the latest version (14.2.3). Anything older than 14.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get latest-post-shortcode --field=version shows what you run; wp plugin update latest-post-shortcode updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-31916 · published 2026-03-13
Missing authorization check in Latest Post Shortcode (14.2.1 and older)
- Affected
- 14.2.1 and older
- Fixed in
- 14.2.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Iulia Cazan Latest Post Shortcode latest-post-shortcode allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Latest Post Shortcode: from n/a through <= 14.2.1.
medium 4.3 CVE-2026-24995 · published 2026-02-03
Missing authorization check in Latest Post Shortcode (14.2.0 and older)
- Affected
- 14.2.0 and older
- Fixed in
- 14.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Iulia Cazan Latest Post Shortcode latest-post-shortcode allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Latest Post Shortcode: from n/a through <= 14.2.0.
medium 6.5 CVE-2025-58609 · published 2025-09-03
Stored cross-site scripting (XSS) in Latest Post Shortcode (14.0.3 and older)
- Affected
- 14.0.3 and older
- Fixed in
- 14.10
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Iulia Cazan Latest Post Shortcode latest-post-shortcode allows Stored XSS.This issue affects Latest Post Shortcode: from n/a through <= 14.0.3.
Recent activity
- 2026-04-10 — latest release on wordpress.org (14.2.3).
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-31916), fixed in 14.2.2.
- 2026-02-03 — Missing authorization check disclosed (CVE-2026-24995), fixed in 14.2.1.
- 2025-09-03 — Stored cross-site scripting (XSS) disclosed (CVE-2025-58609), fixed in 14.10.
Get an email when Latest Post Shortcode has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Latest Post Shortcode (latest-post-shortcode) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Iulia Cazan (2 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/latest-post-shortcode (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/latest-post-shortcode"><img src="https://laskyr.com/plugins/latest-post-shortcode/badge.svg" alt="Latest Post Shortcode vulnerability status"></a>