Plugins · kwayy-html-sitemap · data as of 2026-11-04
Is Kwayy HTML Sitemap safe? Known vulnerabilities and latest version
- Latest version
- 5.2
- Last updated
- 2026-09-07
- Active installs
- 6,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Generate a clean, SEO-friendly HTML sitemap for WordPress. Supports Posts, Pages, Custom Post Types, Taxonomies, and WooCommerce. — by Bimal Rekhadiya
What to do
- Update to the latest version (5.2). Anything older than 5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get kwayy-html-sitemap --field=version shows what you run; wp plugin update kwayy-html-sitemap updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-65539 · published 2026-07-23
Cross-site request forgery (CSRF) in Kwayy HTML Sitemap (4.0 and older)
- Affected
- 4.0 and older
- Fixed in
- 5.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Request Forgery (CSRF) in Kwayy HTML Sitemap <= 4.0 versions.
medium 4.8 CVE-2022-3835 · published 2022-12-26
Stored cross-site scripting (XSS) in Kwayy HTML Sitemap (older than 4.0)
- Affected
- older than 4.0
- Fixed in
- 4.0
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Kwayy HTML Sitemap WordPress plugin before 4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Recent activity
- 2026-09-07 — latest release on wordpress.org (5.2).
- 2026-07-23 — Cross-site request forgery (CSRF) disclosed (CVE-2026-65539), fixed in 5.0.
- 2022-12-26 — Stored cross-site scripting (XSS) disclosed (CVE-2022-3835), fixed in 4.0.
Get an email when Kwayy HTML Sitemap has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Kwayy HTML Sitemap (kwayy-html-sitemap) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/kwayy-html-sitemap (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/kwayy-html-sitemap"><img src="https://laskyr.com/plugins/kwayy-html-sitemap/badge.svg" alt="Kwayy HTML Sitemap vulnerability status"></a>