Plugins · kunze-law · data as of 2026-11-04
Is Kunze Law safe? Known vulnerabilities and latest version
- Status
- Closed 2026-01-08
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate kunze-law && wp plugin delete kunze-law
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 4.4 CVE-2025-15486 · published 2026-01-14
Stored cross-site scripting (XSS) in Kunze Law (2.1 and older)
- Affected
- 2.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Kunze Law plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin's shortcode in all versions up to, and including, 2.1 due to the plugin fetching HTML content from a remote server and injecting it into pages without any sanitization or escaping. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled. Additional presence of a path traversal vulnerability in the shortcode name allows writing malicious HTML files to arbitrary writable locations on the server.
medium 4.8 CVE-2022-0674 · published 2022-03-14
Cross-site scripting (XSS) in Kunze Law (older than 2.1)
- Affected
- older than 2.1
- Fixed in
- 2.1
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Kunze Law WordPress plugin before 2.1 does not escape its 'E-Mail Error "From" Address' settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Recent activity
- 2026-01-08 — closed on wordpress.org (Security Issue).
- 2026-01-14 — Stored cross-site scripting (XSS) disclosed (CVE-2025-15486), fix version not stated.
- 2022-03-14 — Cross-site scripting (XSS) disclosed (CVE-2022-0674), fixed in 2.1.
Get an email when Kunze Law has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Kunze Law (kunze-law) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/kunze-law (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/kunze-law"><img src="https://laskyr.com/plugins/kunze-law/badge.svg" alt="Kunze Law vulnerability status"></a>