Skip to content
Laskyr

Plugins · knowledgebase · data as of 2026-11-04

Is Knowledge Base safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.4)

As of 2026-11-04. 4 issues are on record for older versions; version 3.2.1 or newer fixes all of them that state a fix.

Latest version
3.2.4
Last updated
2026-11-03
Active installs
100+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Build a multi-product knowledge base for WordPress. Reduce support tickets with self-service docs, FAQs, and a built-in help center. — by Ajay

What to do

  1. Update to the latest version (3.2.4). Anything older than 3.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get knowledgebase --field=version shows what you run; wp plugin update knowledgebase updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-108499 · published 2026-10-15

Missing authorization check in Knowledge Base (3.2.0 and older)

Affected
3.2.0 and older
Fixed in
3.2.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WebberZone Knowledge Base knowledgebase allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Knowledge Base: from n/a through 3.2.0.

NVD CVE-2026-108499Patchstack advisory

medium 4.4 CVE-2025-7431 · published 2025-07-18

Stored cross-site scripting (XSS) in Knowledge Base (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.3.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Knowledge Base plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin slug setting in all versions up to, and including, 2.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-7431Wordfence advisoryPlugin source

medium 6.4 CVE-2025-5533 · published 2025-06-06

Stored cross-site scripting (XSS) in Knowledge Base (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Knowledge Base plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'kbalert' shortcode in all versions up to, and including, 2.3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-5533Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-51677 · published 2024-11-04

Stored cross-site scripting (XSS) in Knowledge Base (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ajay Knowledge Base knowledgebase allows Stored XSS.This issue affects Knowledge Base: from n/a through <= 2.2.0.

NVD CVE-2024-51677Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Knowledge Base vulnerability status badge
<a href="https://laskyr.com/plugins/knowledgebase"><img src="https://laskyr.com/plugins/knowledgebase/badge.svg" alt="Knowledge Base vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit