Skip to content
Laskyr

Plugins · knit-pay · data as of 2026-11-04

Is Knit Pay safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.6.3.1)

As of 2026-11-04. 4 issues are on record for older versions; version 9.6.3.1 or newer fixes all of them that state a fix.

Latest version
9.6.3.1
Last updated
2026-10-19
Active installs
2,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Seamlessly integrates 500+ payment gateways, including Cashfree, Instamojo, PayPal, Razorpay, and SSLCommerz, with over 100 WordPress plugins. — by KnitPay

What to do

  1. Update to the latest version (9.6.3.1). Anything older than 9.6.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get knit-pay --field=version shows what you run; wp plugin update knit-pay updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-112821 · published 2026-10-23

Missing authorization check in Knit Pay (9.6.3.0 and older)

Affected
9.6.3.0 and older
Fixed in
9.6.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Knit Pay Knit Pay knit-pay allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Knit Pay: from n/a through 9.6.3.0.

NVD CVE-2026-112821Patchstack advisory

high 8.8 CVE-2026-89426 · published 2026-09-25

Privilege escalation in Knit Pay (9.6.1.0 and older)

Affected
9.6.1.0 and older
Fixed in
9.6.2.0-beta.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Knit Pay – Cashfree, Instamojo, Razorpay, PayPal and more plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 9.6.1.0. This is due to the `maybe_update_user_role()` function reading the target role directly from an attacker-controlled Gravity Forms entry field — configured via the feed's `user_role_field_id` — and passing it to `WP_User::set_role()` without validating the supplied value against an allowlist of permitted roles. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to administrator by tampering with the hidden role field value at form submission time. Exploitation is further enabled by the fact that $0 orders are synchronously marked as SUCCESS during form submission without requiring a real payment, and when no GF User Registration user can be resolved, the role assignment target falls back to `$lead['created_by']` — the currently authenticated submitter's own user ID — making any authenticated form submitter an eligible exploitation target.

NVD CVE-2026-89426Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-57717 · published 2026-07-23

Missing authorization check in Knit Pay (9.6.0.0 and older)

Affected
9.6.0.0 and older
Fixed in
9.6.0.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Knit Pay <= 9.6.0.0 versions.

NVD CVE-2026-57717Patchstack advisory

high 7.5 CVE-2026-49070 · published 2026-06-15

Missing authorization check in Knit Pay (9.4.0.0 and older)

Affected
9.4.0.0 and older
Fixed in
9.4.0.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Knit Pay <= 9.4.0.0 versions.

NVD CVE-2026-49070Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Knit Pay vulnerability status badge
<a href="https://laskyr.com/plugins/knit-pay"><img src="https://laskyr.com/plugins/knit-pay/badge.svg" alt="Knit Pay vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit