Skip to content
Laskyr

Plugins · kia-subtitle · data as of 2026-11-04

Is KIA Subtitle safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.0)

As of 2026-11-04. 1 issue is on record for older versions; version 4.0.2 or newer fixes all of them that state a fix.

Latest version
4.1.0
Last updated
2026-10-21
Active installs
7,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

The KIA Subtitle plugin allows you to add a subtitle to your posts. — by HelgaTheViking

What to do

  1. Update to the latest version (4.1.0). Anything older than 4.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get kia-subtitle --field=version shows what you run; wp plugin update kia-subtitle updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-7509 · published 2026-05-22

Stored cross-site scripting (XSS) in KIA Subtitle (4.0.1 and older)

Affected
4.0.1 and older
Fixed in
4.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The KIA Subtitle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `the-subtitle` shortcode `before` and `after` attributes in all versions up to, and including, 4.0.1. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-7509Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
KIA Subtitle vulnerability status badge
<a href="https://laskyr.com/plugins/kia-subtitle"><img src="https://laskyr.com/plugins/kia-subtitle/badge.svg" alt="KIA Subtitle vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit