Plugins · keep-backup-daily · data as of 2026-11-04
Is Keep Backup Daily safe? Known vulnerabilities and latest version
- Latest version
- 2.2.0
- Last updated
- 2026-10-30
- Active installs
- 200+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Keep Backup Daily backup your wordpress database and email to you daily, weekly, monthly and even yearly according to the settings. — by Fahad Mahmood
What to do
- Update to the latest version (2.2.0). Anything older than 2.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get keep-backup-daily --field=version shows what you run; wp plugin update keep-backup-daily updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2026-3577 · published 2026-03-21
Stored cross-site scripting (XSS) in Keep Backup Daily (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Keep Backup Daily plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the backup title alias (`val` parameter) in the `update_kbd_bkup_alias` AJAX action in all versions up to, and including, 2.1.2. This is due to insufficient input sanitization and output escaping. While `sanitize_text_field()` strips HTML tags on save, it does not encode double quotes. The backup titles are output in HTML attribute contexts without `esc_attr()`. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts via attribute injection that will execute whenever another administrator views the backup list page.
NVD CVE-2026-3577Wordfence advisoryCode change (fix)Plugin source
low 2.7 CVE-2026-3339 · published 2026-03-21
Path traversal / file read in Keep Backup Daily (2.1.1 and older)
- Affected
- 2.1.1 and older
- Fixed in
- 2.1.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Keep Backup Daily plugin for WordPress is vulnerable to Limited Path Traversal in all versions up to, and including, 2.1.1 via the `kbd_open_upload_dir` AJAX action. This is due to insufficient validation of the `kbd_path` parameter, which is only sanitized with `sanitize_text_field()` - a function that does not strip path traversal sequences. This makes it possible for authenticated attackers, with Administrator-level access and above, to list the contents of arbitrary directories on the server outside of the intended uploads directory.
NVD CVE-2026-3339Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2025-26779 · published 2025-02-16
Path traversal / file read in Keep Backup Daily (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Fahad Mahmood Keep Backup Daily keep-backup-daily allows Path Traversal.This issue affects Keep Backup Daily: from n/a through <= 2.1.0.
high 7.5 CVE-2024-48024 · published 2024-10-17
Information disclosure in Keep Backup Daily (2.1.3 and older)
- Affected
- 2.1.3 and older
- Fixed in
- 2.1.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Fahad Mahmood Keep Backup Daily keep-backup-daily allows Retrieve Embedded Sensitive Data.This issue affects Keep Backup Daily: from n/a through <= 2.1.3.
medium 6.1 CVE-2022-1820 · published 2022-06-13
Reflected cross-site scripting (XSS) in Keep Backup Daily (2.0.2 and older)
- Affected
- 2.0.2 and older
- Fixed in
- 2.1.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Keep Backup Daily plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘t’ parameter in versions up to, and including, 2.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2022-1820Wordfence advisoryCode change (fix)wordpress.orgWordfence advisory
Recent activity
- 2026-10-30 — latest release on wordpress.org (2.2.0).
- 2026-03-21 — Stored cross-site scripting (XSS) disclosed (CVE-2026-3577), fixed in 2.1.3.
- 2026-03-21 — Path traversal / file read disclosed (CVE-2026-3339), fixed in 2.1.2.
- 2025-02-16 — Path traversal / file read disclosed (CVE-2025-26779), fixed in 2.1.1.
Get an email when Keep Backup Daily has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Keep Backup Daily (keep-backup-daily) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Fahad Mahmood (9 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Path traversal and file read (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/keep-backup-daily (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/keep-backup-daily"><img src="https://laskyr.com/plugins/keep-backup-daily/badge.svg" alt="Keep Backup Daily vulnerability status"></a>