Skip to content
Laskyr

Plugins · kalender-digital · data as of 2026-11-04

Is Calendar.online / Kalender.digital safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.14)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.14 or newer fixes all of them that state a fix.

Latest version
1.0.14
Last updated
2026-07-17
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.3+

Plugin for the integration of a free calendar from Calendar.online or Kalender.digital — by kalender.digital

What to do

  1. Update to the latest version (1.0.14). Anything older than 1.0.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get kalender-digital --field=version shows what you run; wp plugin update kalender-digital updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62752 · published 2025-12-31

Cross-site scripting (XSS) in Calendar.online / Kalender.digital (1.0.13 and older)

Affected
1.0.13 and older
Fixed in
1.0.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in kalender.digital Kalender.digital kalender-digital allows DOM-Based XSS.This issue affects Kalender.digital: from n/a through <= 1.0.13.

NVD CVE-2025-62752Patchstack advisory

medium 6.5 CVE-2024-38678 · published 2024-07-20

Stored cross-site scripting (XSS) in Calendar.online / Kalender.digital (1.0.8 and older)

Affected
1.0.8 and older
Fixed in
1.0.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Calendar.Online Calendar.Online / Kalender.Digital allows Stored XSS.This issue affects Calendar.Online / Kalender.Digital: from n/a through 1.0.8.

NVD CVE-2024-38678Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Calendar.online / Kalender.digital vulnerability status badge
<a href="https://laskyr.com/plugins/kalender-digital"><img src="https://laskyr.com/plugins/kalender-digital/badge.svg" alt="Calendar.online / Kalender.digital vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit