Plugins · kadence-woocommerce-email-designer · data as of 2026-11-04
Is Kadence WooCommerce Email Designer safe? Known vulnerabilities and latest version
- Latest version
- 1.5.19.2
- Last updated
- 2026-09-21
- Active installs
- 90,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.2.4+
Customize the default WooCommerce email templates design and text through the native WordPress customizer. Preview emails and send test emails. — by Nexcess
What to do
- Update to the latest version (1.5.19.2). Anything older than 1.5.19.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get kadence-woocommerce-email-designer --field=version shows what you run; wp plugin update kadence-woocommerce-email-designer updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-94677 · published 2026-09-30
PHP object injection in Kadence WooCommerce Email Designer (1.5.19.1 and older)
- Affected
- 1.5.19.1 and older
- Fixed in
- 1.5.19.2
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Shop manager PHP Object Injection in Kadence WooCommerce Email Designer <= 1.5.19.1 versions.
critical 9.8 CVE-2026-28005 · published 2026-08-06
Privilege escalation in Kadence WooCommerce Email Designer (1.5.19 and older)
- Affected
- 1.5.19 and older
- Fixed in
- 1.5.19.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Privilege Escalation in Kadence WooCommerce Email Designer <= 1.5.19 versions.
high 7.2 CVE-2025-13387 · published 2025-12-02
Stored cross-site scripting (XSS) in Kadence WooCommerce Email Designer (1.5.17 and older)
- Affected
- 1.5.17 and older
- Fixed in
- 1.5.18 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Kadence WooCommerce Email Designer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the customer name in all versions up to, and including, 1.5.17 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 7.2 CVE-2025-54697 · published 2025-08-14
Privilege escalation in Kadence WooCommerce Email Designer (1.5.16 and older)
- Affected
- 1.5.16 and older
- Fixed in
- 1.5.17
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Incorrect Privilege Assignment vulnerability in StellarWP Kadence WooCommerce Email Designer kadence-woocommerce-email-designer allows Privilege Escalation.This issue affects Kadence WooCommerce Email Designer: from n/a through <= 1.5.16.
critical 9.1 CVE-2025-39557 · published 2025-04-16
Arbitrary file upload in Kadence WooCommerce Email Designer (1.5.14 and older)
- Affected
- 1.5.14 and older
- Fixed in
- 1.5.15
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in StellarWP Kadence WooCommerce Email Designer kadence-woocommerce-email-designer allows Upload a Web Shell to a Web Server.This issue affects Kadence WooCommerce Email Designer: from n/a through <= 1.5.14.
high 8.8 CVE-2023-47186 · published 2023-11-06
Cross-site request forgery (CSRF) in Kadence WooCommerce Email Designer (1.5.11 and older)
- Affected
- 1.5.11 and older
- Fixed in
- 1.5.12
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Kadence WP Kadence WooCommerce Email Designer plugin <= 1.5.11 versions.
high 7.2 CVE-2022-3335 · published 2022-10-25
PHP object injection in Kadence WooCommerce Email Designer (older than 1.5.7)
- Affected
- older than 1.5.7
- Fixed in
- 1.5.7
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Kadence WooCommerce Email Designer WordPress plugin before 1.5.7 unserialises the content of an imported file, which could lead to PHP object injections issues when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.
Recent activity
- 2026-09-21 — latest release on wordpress.org (1.5.19.2).
- 2026-09-30 — PHP object injection disclosed (CVE-2026-94677), fixed in 1.5.19.2.
- 2026-08-06 — Privilege escalation disclosed (CVE-2026-28005), fixed in 1.5.19.1.
- 2025-12-02 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13387), fixed in 1.5.18.
Get an email when Kadence WooCommerce Email Designer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Kadence WooCommerce Email Designer (kadence-woocommerce-email-designer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Nexcess (14 tracked)
Types found in this plugin: PHP object injection (2) · Privilege escalation (2) · Cross-site scripting (XSS) (1) · Arbitrary file upload (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/kadence-woocommerce-email-designer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/kadence-woocommerce-email-designer"><img src="https://laskyr.com/plugins/kadence-woocommerce-email-designer/badge.svg" alt="Kadence WooCommerce Email Designer vulnerability status"></a>