Plugins · jw-player-7-for-wp · data as of 2026-11-04
Is JW Player for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 2.3.12
- Last updated
- 2026-09-18
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
JW Player for WordPress enables you to publish videos on your WordPress posts and pages using the most popular video player on the web. — by ilGhera
What to do
- Update to the latest version (2.3.12). Anything older than 2.3.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get jw-player-7-for-wp --field=version shows what you run; wp plugin update jw-player-7-for-wp updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-93512 · published 2026-09-30
Cross-site scripting (XSS) in JW Player for WordPress (2.3.11 and older)
- Affected
- 2.3.11 and older
- Fixed in
- 2.3.12
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in JW Player for WordPress <= 2.3.11 versions.
medium 5.4 CVE-2026-39614 · published 2026-04-08
Missing authorization check in JW Player for WordPress (2.3.6 and older)
- Affected
- 2.3.6 and older
- Fixed in
- 2.3.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in ilGhera JW Player for WordPress jw-player-7-for-wp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects JW Player for WordPress: from n/a through <= 2.3.6.
medium 6.5 CVE-2024-33931 · published 2024-05-03
Missing authorization check in JW Player for WordPress (2.3.3 and older)
- Affected
- 2.3.3 and older
- Fixed in
- 2.3.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in ilGhera JW Player for WordPress.This issue affects JW Player for WordPress: from n/a through 2.3.3.
Recent activity
- 2026-09-18 — latest release on wordpress.org (2.3.12).
- 2026-09-30 — Cross-site scripting (XSS) disclosed (CVE-2026-93512), fixed in 2.3.12.
- 2026-04-08 — Missing authorization check disclosed (CVE-2026-39614), fixed in 2.3.7.
- 2024-05-03 — Missing authorization check disclosed (CVE-2024-33931), fixed in 2.3.4.
Get an email when JW Player for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for JW Player for WordPress (jw-player-7-for-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ilGhera (4 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/jw-player-7-for-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/jw-player-7-for-wp"><img src="https://laskyr.com/plugins/jw-player-7-for-wp/badge.svg" alt="JW Player for WordPress vulnerability status"></a>