Plugins · json-api-user · data as of 2026-11-04
Is JSON API User safe? Known vulnerabilities and latest version
- Latest version
- 4.1.4
- Last updated
- 2026-09-07
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Extends the JSON API Plugin to allow RESTful user registration, authentication & many other User Meta, BP functions. A Pro version is also available. — by Ali Qureshi
What to do
- Update to the latest version (4.1.4). Anything older than 4.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get json-api-user --field=version shows what you run; wp plugin update json-api-user updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-9626 · published 2026-07-03
Stored cross-site scripting (XSS) in JSON API User (4.1.0 and older)
- Affected
- 4.1.0 and older
- Fixed in
- 4.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The JSON API User plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content' parameter of the post_comment API endpoint in versions up to, and including, 4.1.0 This is due to insufficient input sanitization in the post_comment() function, which passes the attacker-controlled comment_content value directly to wp_insert_comment() without applying any HTML sanitization, and additionally allows the caller to set comment_approved=1 to self-approve the comment and bypass moderation. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-9626Wordfence advisoryCode change (fix)Plugin source
critical 9.8 CVE-2024-6624 · published 2024-07-11
Privilege escalation in JSON API User (3.9.3 and older)
- Affected
- 3.9.3 and older
- Fixed in
- 3.9.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The JSON API User plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.9.3. This is due to improper controls on custom user meta fields. This makes it possible for unauthenticated attackers to register as administrators on the site. The plugin requires the JSON API plugin to also be installed.
NVD CVE-2024-6624Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-07 — latest release on wordpress.org (4.1.4).
- 2026-07-03 — Stored cross-site scripting (XSS) disclosed (CVE-2026-9626), fixed in 4.1.2.
- 2024-07-11 — Privilege escalation disclosed (CVE-2024-6624), fixed in 3.9.4.
Get an email when JSON API User has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for JSON API User (json-api-user) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ali Qureshi (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/json-api-user (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/json-api-user"><img src="https://laskyr.com/plugins/json-api-user/badge.svg" alt="JSON API User vulnerability status"></a>