Skip to content
Laskyr

Plugins · jquery-archive-list-widget · data as of 2026-11-04

Is JS Archive List safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.3.1)

As of 2026-11-04. 4 issues are on record for older versions; version 6.2.0 or newer fixes all of them that state a fix.

Latest version
6.3.1
Last updated
2026-04-03
Active installs
3,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

A JS widget (can be used in posts) for displaying an archive list with some effects. — by Miguel Useche

What to do

  1. Update to the latest version (6.3.1). Anything older than 6.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get jquery-archive-list-widget --field=version shows what you run; wp plugin update jquery-archive-list-widget updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-32513 · published 2026-03-25

PHP object injection in JS Archive List (6.1.7 and older)

Affected
6.1.7 and older
Fixed in
6.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Miguel Useche JS Archive List jquery-archive-list-widget allows Object Injection.This issue affects JS Archive List: from n/a through <= 6.1.7.

NVD CVE-2026-32513Patchstack advisory

high 7.5 CVE-2026-2020 · published 2026-03-07

PHP object injection in JS Archive List (6.1.7 and older)

Affected
6.1.7 and older
Fixed in
6.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The JS Archive List plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 6.1.7 via the 'included' shortcode attribute. This is due to the deserialization of untrusted input supplied via the 'included' parameter of the plugin's shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2026-2020Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2025-54726 · published 2025-08-20

SQL injection in JS Archive List (6.1.6 and older)

Affected
6.1.6 and older
Fixed in
6.1.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Miguel Useche JS Archive List jquery-archive-list-widget allows SQL Injection.This issue affects JS Archive List: from n/a through < 6.1.6.

NVD CVE-2025-54726Patchstack advisory

high 7.5 CVE-2025-7670 · published 2025-08-19

SQL injection in JS Archive List (6.1.5 and older)

Affected
6.1.5 and older
Fixed in
6.1.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The JS Archive List plugin for WordPress is vulnerable to time-based SQL Injection via the build_sql_where() function in all versions up to, and including, 6.1.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-7670Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
JS Archive List vulnerability status badge
<a href="https://laskyr.com/plugins/jquery-archive-list-widget"><img src="https://laskyr.com/plugins/jquery-archive-list-widget/badge.svg" alt="JS Archive List vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit