Plugins · jobwp · data as of 2026-11-04
Is JobWP safe? Known vulnerabilities and latest version
- Latest version
- 2.5.1
- Last updated
- 2026-10-20
- Active installs
- 1,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Build a job board in WordPress with Google Jobs support, built-in application management, and reCAPTCHA — free. No coding needed. — by Hossni Mubarak
What to do
- Update to the latest version (2.5.1). Anything older than 2.4.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get jobwp --field=version shows what you run; wp plugin update jobwp updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2025-69318 · published 2026-01-22
Stored cross-site scripting (XSS) in JobWP (2.4.5 and older)
- Affected
- 2.4.5 and older
- Fixed in
- 2.4.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Hossni Mubarak JobWP jobwp allows Stored XSS.This issue affects JobWP: from n/a through <= 2.4.5.
medium 4.3 CVE-2025-57895 · published 2025-08-22
Cross-site request forgery (CSRF) in JobWP (2.4.3 and older)
- Affected
- 2.4.3 and older
- Fixed in
- 2.4.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Hossni Mubarak JobWP jobwp allows Cross Site Request Forgery.This issue affects JobWP: from n/a through <= 2.4.3.
medium 4.3 CVE-2025-49975 · published 2025-06-20
Cross-site request forgery (CSRF) in JobWP (2.4.0 and older)
- Affected
- 2.4.0 and older
- Fixed in
- 2.4.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Hossni Mubarak JobWP jobwp allows Cross Site Request Forgery.This issue affects JobWP: from n/a through <= 2.4.0.
high 7.5 CVE-2025-2010 · published 2025-04-19
SQL injection in JobWP (2.3.9 and older)
- Affected
- 2.3.9 and older
- Fixed in
- 2.4.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The JobWP – Job Board, Job Listing, Career Page and Recruitment Plugin plugin for WordPress is vulnerable to SQL Injection via the 'jobwp_upload_resume' parameter in all versions up to, and including, 2.3.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
medium 4.3 CVE-2025-32265 · published 2025-04-04
Cross-site request forgery (CSRF) in JobWP (2.3.9 and older)
- Affected
- 2.3.9 and older
- Fixed in
- 2.4.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Hossni Mubarak JobWP jobwp allows Cross Site Request Forgery.This issue affects JobWP: from n/a through <= 2.3.9.
high 7.5 CVE-2023-48288 · published 2023-12-21
Information disclosure in JobWP (2.1 and older)
- Affected
- 2.1 and older
- Fixed in
- 2.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in HM Plugin WordPress Job Board and Recruitment Plugin – JobWP.This issue affects WordPress Job Board and Recruitment Plugin – JobWP: from n/a through 2.1.
critical 9.8 CVE-2023-29384 · published 2023-12-20
Arbitrary file upload in JobWP (2.0 and older)
- Affected
- 2.0 and older
- Fixed in
- 2.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in HM Plugin WordPress Job Board and Recruitment Plugin – JobWP.This issue affects WordPress Job Board and Recruitment Plugin – JobWP: from n/a through 2.0.
Recent activity
- 2026-10-20 — latest release on wordpress.org (2.5.1).
- 2026-01-22 — Stored cross-site scripting (XSS) disclosed (CVE-2025-69318), fixed in 2.4.6.
- 2025-08-22 — Cross-site request forgery (CSRF) disclosed (CVE-2025-57895), fixed in 2.4.4.
- 2025-06-20 — Cross-site request forgery (CSRF) disclosed (CVE-2025-49975), fixed in 2.4.1.
Get an email when JobWP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for JobWP (jobwp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Hossni Mubarak (2 tracked)
Types found in this plugin: Cross-site request forgery (CSRF) (3) · Cross-site scripting (XSS) (1) · SQL injection (1) · Sensitive data exposure (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/jobwp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/jobwp"><img src="https://laskyr.com/plugins/jobwp/badge.svg" alt="JobWP vulnerability status"></a>