Plugins · job-board · data as of 2026-11-04
Is Job Board by BestWebSoft safe? Known vulnerabilities and latest version
- Latest version
- 1.2.2
- Last updated
- 2025-11-26
- Active installs
- 70+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 5.7.21
Create your personal job board and listing WordPress website. Search jobs, submit CV/resumes, choose candidates. — by bestweblayout
What to do
- Update to the latest version (1.2.2). Anything older than 1.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get job-board --field=version shows what you run; wp plugin update job-board updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2025-13383 · published 2025-11-25
Stored cross-site scripting (XSS) in Job Board by BestWebSoft (1.2.1 and older)
- Affected
- 1.2.1 and older
- Fixed in
- 1.2.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Job Board by BestWebSoft plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 1.2.1. This is due to the plugin storing the entire unsanitized `$_GET` superglobal array directly into the database via `update_user_meta()` when users save search results, and later outputting this data without proper escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute whenever a user accesses the saved search or views their profile, granted they can trick the user into performing the search and saving the results.
NVD CVE-2025-13383Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2025-11-26 — latest release on wordpress.org (1.2.2).
- 2025-11-25 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13383), fixed in 1.2.2.
Get an email when Job Board by BestWebSoft has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Job Board by BestWebSoft (job-board) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bestweblayout (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/job-board (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/job-board"><img src="https://laskyr.com/plugins/job-board/badge.svg" alt="Job Board by BestWebSoft vulnerability status"></a>