Plugins · jay-login-register · data as of 2026-11-04
Is JAY Login & Register safe? Known vulnerabilities and latest version
- Latest version
- 2.6.12
- Last updated
- 2026-10-18
- Active installs
- 100+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
All-in-One Mobile OTP Login, Registration, Content Restriction, and Advanced Role Management plugin. Supports SMS, Email, Google, Eitaa, and Gravity F … — by jayarsiech
What to do
- Update to the latest version (2.6.12). Anything older than 2.6.04 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get jay-login-register --field=version shows what you run; wp plugin update jay-login-register updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2025-15027 · published 2026-02-08
Privilege escalation in JAY Login & Register (2.6.03 and older)
- Affected
- 2.6.03 and older
- Fixed in
- 2.6.04 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The JAY Login & Register plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.6.03. This is due to the plugin allowing a user to update arbitrary user meta through the 'jay_login_register_ajax_create_final_user' function. This makes it possible for unauthenticated attackers to elevate their privileges to that of an administrator.
high 8.8 CVE-2025-15100 · published 2026-02-08
Privilege escalation in JAY Login & Register (2.6.03 and older)
- Affected
- 2.6.03 and older
- Fixed in
- 2.6.04 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The JAY Login & Register plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.6.03. This is due to the plugin allowing a user to update arbitrary user meta through the 'jay_panel_ajax_update_profile' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to that of an administrator.
critical 9.8 CVE-2025-14440 · published 2025-12-13
Authentication bypass in JAY Login & Register (2.4.01 and older)
- Affected
- 2.4.01 and older
- Fixed in
- 2.5.01 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The JAY Login & Register plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.4.01. This is due to incorrect authentication checking in the 'jay_login_register_process_switch_back' function with the 'jay_login_register_process_switch_back' cookie value. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id.
NVD CVE-2025-14440Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-18 — latest release on wordpress.org (2.6.12).
- 2026-02-08 — Privilege escalation disclosed (CVE-2025-15027), fixed in 2.6.04.
- 2026-02-08 — Privilege escalation disclosed (CVE-2025-15100), fixed in 2.6.04.
- 2025-12-13 — Authentication bypass disclosed (CVE-2025-14440), fixed in 2.5.01.
Get an email when JAY Login & Register has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for JAY Login & Register (jay-login-register) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (2) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/jay-login-register (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/jay-login-register"><img src="https://laskyr.com/plugins/jay-login-register/badge.svg" alt="JAY Login & Register vulnerability status"></a>