Skip to content
Laskyr

Plugins · javascript-notifier · data as of 2026-11-04

Is JavaScript Notifier safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.9)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
1.2.9
Last updated
2026-08-21
Active installs
50+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

JavaScript Notifier allows you to inform visitors that your website requires JavaScript. — by freemp

What to do

  1. Update to the latest version (1.2.9). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get javascript-notifier --field=version shows what you run; wp plugin update javascript-notifier updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-1191 · published 2026-01-24

Stored cross-site scripting (XSS) in JavaScript Notifier (1.2.8 and older)

Affected
1.2.8 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The JavaScript Notifier plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin settings in all versions up to, and including, 1.2.8. This is due to insufficient input sanitization and output escaping on user-supplied attributes in the `wp_footer` action. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1191Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
JavaScript Notifier vulnerability status badge
<a href="https://laskyr.com/plugins/javascript-notifier"><img src="https://laskyr.com/plugins/javascript-notifier/badge.svg" alt="JavaScript Notifier vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit