Skip to content
Laskyr

Plugins · iubenda-cookie-law-solution · data as of 2026-11-04

Is iubenda safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.13.7)

As of 2026-11-04. 4 issues are on record for older versions; version 3.13.5 or newer fixes all of them that state a fix.

Latest version
3.13.7
Last updated
2026-11-02
Active installs
200,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0.0+

The solution for GDPR compliance + more. Get your cookie banner, privacy policy, terms and conditions and handle cookie consent in just one plugin. — by iubenda

What to do

  1. Update to the latest version (3.13.7). Anything older than 3.13.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get iubenda-cookie-law-solution --field=version shows what you run; wp plugin update iubenda-cookie-law-solution updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-77233 · published 2026-09-05

Stored cross-site scripting (XSS) in iubenda (3.13.4 and older)

Affected
3.13.4 and older
Fixed in
3.13.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The iubenda | All-in-one Compliance for GDPR / CCPA Cookie Consent + more plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via AdSense Regex Rewrite in all versions up to, and including, 3.13.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability only manifests when the 'Secondary' parser engine is active (parser_engine=default); it does not exist under the default 'new' DOM-based parser engine.

NVD CVE-2026-77233Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-77263 · published 2026-09-05

Stored cross-site scripting (XSS) in iubenda (3.13.4 and older)

Affected
3.13.4 and older
Fixed in
3.13.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The iubenda | All-in-one Compliance for GDPR / CCPA Cookie Consent + more plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content in all versions up to, and including, 3.13.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit works by embedding KSES-allowed markup such as abbr title attributes and HTML comments in a submitted comment so that the global strtr() substitution strips substrings from an inert tag, mutating it into an executable element such as an img onerror handler that runs in the WordPress origin for any visitor, including logged-in administrators.

NVD CVE-2026-77263Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2022-3911 · published 2023-01-02

Cross-site request forgery (CSRF) in iubenda (older than 3.3.3)

Affected
older than 3.3.3
Fixed in
3.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The iubenda WordPress plugin before 3.3.3 does does not have authorisation and CSRF in an AJAX action, and does not ensure that the options to be updated belong to the plugin as long as they are arrays. As a result, any authenticated users, such as subscriber can grant themselves any privileges, such as edit_plugins etc

NVD CVE-2022-3911WPScan advisory

medium 6.1 CVE-2020-12742 · published 2020-05-13

Security issue in iubenda (older than 2.3.5)

Affected
older than 2.3.5
Fixed in
2.3.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The iubenda-cookie-law-solution plugin before 2.3.5 for WordPress does not restrict URL sanitization to http protocols.

NVD CVE-2020-12742wordpress.orggithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
iubenda vulnerability status badge
<a href="https://laskyr.com/plugins/iubenda-cookie-law-solution"><img src="https://laskyr.com/plugins/iubenda-cookie-law-solution/badge.svg" alt="iubenda vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit