Skip to content
Laskyr

Plugins · iteras · data as of 2026-11-04

Is ITERAS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.8.3 or newer fixes all of them that state a fix.

Latest version
1.9.0
Last updated
2026-10-27
Active installs
30+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Integration with ITERAS, a cloud-based state-of-the-art system for managing subscriptions and payments for magazines. — by ITERAS

What to do

  1. Update to the latest version (1.9.0). Anything older than 1.8.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get iteras --field=version shows what you run; wp plugin update iteras updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4078 · published 2026-04-24

Stored cross-site scripting (XSS) in ITERAS (1.8.2 and older)

Affected
1.8.2 and older
Fixed in
1.8.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ITERAS plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple shortcodes (iteras-ordering, iteras-signup, iteras-paywall-login, iteras-selfservice) in all versions up to and including 1.8.2. This is due to insufficient input sanitization and output escaping in the combine_attributes() function. The function directly concatenates shortcode attribute values into JavaScript code within <script> tags using double-quoted string interpolation (line 489: '"'.$key.'": "'.$value.'"') without any escaping. An attacker can break out of the JavaScript string context by including a double-quote character in a shortcode attribute value and inject arbitrary JavaScript. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4078Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2024-53710 · published 2024-12-02

Cross-site request forgery (CSRF) in ITERAS (1.8.0 and older)

Affected
1.8.0 and older
Fixed in
1.8.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in ITERAS ITERAS iteras allows Stored XSS.This issue affects ITERAS: from n/a through <= 1.8.0.

NVD CVE-2024-53710Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ITERAS vulnerability status badge
<a href="https://laskyr.com/plugins/iteras"><img src="https://laskyr.com/plugins/iteras/badge.svg" alt="ITERAS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit