Skip to content
Laskyr

Plugins · ipospays-gateways-wc · data as of 2026-11-04

Is iPOSpays Payment Gateway for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.7 or newer fixes all of them that state a fix.

Latest version
1.4.7
Last updated
2026-10-15
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Accept all major credit/debit cards, ACH (Bank), Apple Pay, Google Pay, PayPal, and other alternative payment methods with WooCommerce. — by iPOSPays

What to do

  1. Update to the latest version (1.4.7). Anything older than 1.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ipospays-gateways-wc --field=version shows what you run; wp plugin update ipospays-gateways-wc updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-86791 · published 2026-10-19

Security issue in iPOSpays Payment Gateway for WooCommerce (older than 1.4.7)

Affected
older than 1.4.7
Fixed in
1.4.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The iPOSpays Payment Gateway for WooCommerce WordPress plugin before 1.4.7 does not verify that a payment was actually completed before recording an order as paid, allowing unauthenticated users to mark any unpaid order as paid and to rewrite its total.

NVD CVE-2026-86791WPScan advisory

medium 5.3 CVE-2026-39608 · published 2026-04-08

Missing authorization check in iPOSpays Payment Gateway for WooCommerce (1.3.7 and older)

Affected
1.3.7 and older
Fixed in
1.3.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in iPOSPays iPOSpays Gateways WC ipospays-gateways-wc allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects iPOSpays Gateways WC: from n/a through <= 1.3.7.

NVD CVE-2026-39608Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
iPOSpays Payment Gateway for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/ipospays-gateways-wc"><img src="https://laskyr.com/plugins/ipospays-gateways-wc/badge.svg" alt="iPOSpays Payment Gateway for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit