Plugins · invoicing · data as of 2026-11-04
Is Payment forms, Buy now buttons, and Invoicing… safe? Known vulnerabilities and latest version
- Latest version
- 2.8.64
- Last updated
- 2026-10-28
- Active installs
- 5,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Payments & Invoicing plugin for WordPress to quickly and easily sell online. Create Buy Now buttons or inline checkout forms in seconds to accept … — by Stiofan
What to do
- Update to the latest version (2.8.64). Anything older than 2.8.63 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get invoicing --field=version shows what you run; wp plugin update invoicing updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-115609 · published 2026-10-28
Stored cross-site scripting (XSS) in Payment forms, Buy now buttons, and Invoicing… (2.8.62 and older)
- Affected
- 2.8.62 and older
- Fixed in
- 2.8.63
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan GetPaid invoicing allows Stored XSS.This issue affects GetPaid: from n/a through 2.8.62.
high 7.2 CVE-2026-111110 · published 2026-10-17
Stored cross-site scripting (XSS) in Payment forms, Buy now buttons, and Invoicing… (2.8.61 and older)
- Affected
- 2.8.61 and older
- Fixed in
- 2.8.62 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment forms, Buy now buttons, and Invoicing System | GetPaid plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'mmdwqzpoxadd' parameter in all versions up to, and including, 2.8.61 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce (getpaid_form_nonce) is publicly emitted to all visitors via wp_localize_script as WPInv.formNonce, meaning no authentication or prior nonce leak is needed; the stored payload fires when an administrator views the affected invoice's Payment Form Details metabox.
NVD CVE-2026-111110Wordfence advisoryCode change (fix)github.comPlugin source
medium 6.6 CVE-2026-17605 · published 2026-08-01
File inclusion in Payment forms, Buy now buttons, and Invoicing… (2.8.56 and older)
- Affected
- 2.8.56 and older
- Fixed in
- 2.8.57 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment forms, Buy now buttons, and Invoicing System | GetPaid plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.8.56 via the getpaid_payment_form_element function. This makes it possible for authenticated attackers, with administrator-level access and above, to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included.
high 7.5 CVE-2026-49064 · published 2026-06-15
Information disclosure in Payment forms, Buy now buttons, and Invoicing… (2.8.49 and older)
- Affected
- 2.8.49 and older
- Fixed in
- 2.8.50
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in Stiofan GetPaid allows Retrieve Embedded Sensitive Data. This issue affects GetPaid: from n/a through 2.8.49.
high 8.8 CVE-2024-43973 · published 2024-11-01
Missing authorization check in Payment forms, Buy now buttons, and Invoicing… (2.8.11 and older)
- Affected
- 2.8.11 and older
- Fixed in
- 2.8.12
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in Stiofan GetPaid invoicing allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GetPaid: from n/a through <= 2.8.11.
Recent activity
- 2026-10-28 — latest release on wordpress.org (2.8.64).
- 2026-10-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-115609), fixed in 2.8.63.
- 2026-10-17 — Stored cross-site scripting (XSS) disclosed (CVE-2026-111110), fixed in 2.8.62.
- 2026-08-01 — File inclusion disclosed (CVE-2026-17605), fixed in 2.8.57.
Get an email when Payment forms, Buy now buttons, and Invoicing… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Payment forms, Buy now buttons, and Invoicing… (invoicing) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Stiofan (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · File inclusion (1) · Sensitive data exposure (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/invoicing (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/invoicing"><img src="https://laskyr.com/plugins/invoicing/badge.svg" alt="Payment forms, Buy now buttons, and Invoicing… vulnerability status"></a>