Skip to content
Laskyr

Plugins · invoice-payment-for-woocommerce · data as of 2026-11-04

Is Link Invoice Payment for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.14.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.8.1 or newer fixes all of them that state a fix.

Latest version
2.14.0
Last updated
2026-10-20
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Link Invoice Payment is an extension for WooCommerce, designed to simplify online billing. Whether for one-time or subscriptions (recurring invoices) — by Link Nacional

What to do

  1. Update to the latest version (2.14.0). Anything older than 2.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get invoice-payment-for-woocommerce --field=version shows what you run; wp plugin update invoice-payment-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-14971 · published 2026-01-27

Missing authorization check in Link Invoice Payment for WooCommerce (2.8.0 and older)

Affected
2.8.0 and older
Fixed in
2.8.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Link Invoice Payment for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the createPartialPayment and cancelPartialPayment functions in all versions up to, and including, 2.8.0. This makes it possible for unauthenticated attackers to create partial payments on any order or cancel any existing partial payment via ID enumeration.

NVD CVE-2025-14971Wordfence advisoryPlugin source

high 7.1 CVE-2024-54328 · published 2024-12-13

Reflected cross-site scripting (XSS) in Link Invoice Payment for WooCommerce (1.7.2 and older)

Affected
1.7.2 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in linknacional Invoice Payment for WooCommerce invoice-payment-for-woocommerce allows Reflected XSS.This issue affects Invoice Payment for WooCommerce: from n/a through <= 1.7.2.

NVD CVE-2024-54328Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Link Invoice Payment for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/invoice-payment-for-woocommerce"><img src="https://laskyr.com/plugins/invoice-payment-for-woocommerce/badge.svg" alt="Link Invoice Payment for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit