Plugins · intuitive-custom-post-order · data as of 2026-11-01
Is Intuitive Custom Post Order safe? Known vulnerabilities and latest version
- Latest version
- 3.2.0
- Last updated
- 2025-09-16
- Active installs
- 400,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12
Intuitively reorder Posts, Pages, Custom Post Types, Taxonomies, and Sites with a simple drag-and-drop interface. — by hijiri
What to do
- Update to the latest version (3.2.0). Anything older than 3.1.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get intuitive-custom-post-order --field=version shows what you run; wp plugin update intuitive-custom-post-order updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2023-1016 · published 2023-06-09
SQL injection in Intuitive Custom Post Order (3.1.4 and older)
- Affected
- 3.1.4 and older
- Fixed in
- 3.1.4.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Intuitive Custom Post Order plugin for WordPress is vulnerable to SQL Injection in versions up to, and including, 3.1.4.1, due to insufficient escaping on the user supplied 'objects' and 'tags' parameters and lack of sufficient preparation in the 'update_options' function as well as the 'refresh' function which runs queries on the same values. This allows authenticated attackers, with administrator permissions, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Note that this attack may only be practical on configurations where it is possible to bypass addslashes due to the database using a nonstandard character set such as GBK.
NVD CVE-2023-1016Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2022-4385 · published 2023-02-21
Missing authorization check in Intuitive Custom Post Order (older than 3.1.4)
- Affected
- older than 3.1.4
- Fixed in
- 3.1.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Intuitive Custom Post Order WordPress plugin before 3.1.4 does not check for authorization in the update-menu-order ajax action, allowing any logged in user (with roles as low as Subscriber) to update the menu order
medium 4.3 CVE-2022-4386 · published 2023-02-21
Cross-site request forgery (CSRF) in Intuitive Custom Post Order (older than 3.1.4)
- Affected
- older than 3.1.4
- Fixed in
- 3.1.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Intuitive Custom Post Order WordPress plugin before 3.1.4 lacks CSRF protection in its update-menu-order ajax action, allowing an attacker to trick any user to change the menu order via a CSRF attack
Recent activity
- 2025-09-16 — latest release on wordpress.org (3.2.0).
- 2023-06-09 — SQL injection disclosed (CVE-2023-1016), fixed in 3.1.4.1.
- 2023-02-21 — Missing authorization check disclosed (CVE-2022-4385), fixed in 3.1.4.
- 2023-02-21 — Cross-site request forgery (CSRF) disclosed (CVE-2022-4386), fixed in 3.1.4.
Get an email when Intuitive Custom Post Order has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Intuitive Custom Post Order (intuitive-custom-post-order) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/intuitive-custom-post-order (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/intuitive-custom-post-order"><img src="https://laskyr.com/plugins/intuitive-custom-post-order/badge.svg" alt="Intuitive Custom Post Order vulnerability status"></a>