Plugins · integration-marktplaats-for-woocommerce · data as of 2026-11-04
Is Woosa safe? Known vulnerabilities and latest version
- Latest version
- 2.1.2
- Last updated
- 2026-08-27
- Active installs
- 50+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.1+
Connects WooCommerce with Marktplaats platform — by Woosa
What to do
- Update to the latest version (2.1.2). Anything older than 2.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get integration-marktplaats-for-woocommerce --field=version shows what you run; wp plugin update integration-marktplaats-for-woocommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-7547 · published 2026-06-19
Path traversal / file read in Woosa (2.0.5 and older)
- Affected
- 2.0.5 and older
- Fixed in
- 2.0.6 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Woosa – Marktplaats for WooCommerce plugin for WordPress is vulnerable to Arbitrary File Read via Path Traversal in versions up to and including 2.0.4. This is due to insufficient path sanitization in the render_logs_ui() function, which accepts a base64-encoded file name from the 'log_file' GET parameter and concatenates it directly with the plugin's log directory path without validating that the resolved path remains within the intended directory. This makes it possible for authenticated attackers, with Administrator-level access, to read the contents of arbitrary files on the server, including wp-config.
NVD CVE-2026-7547Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-27 — latest release on wordpress.org (2.1.2).
- 2026-06-19 — Path traversal / file read disclosed (CVE-2026-7547), fixed in 2.0.6.
Get an email when Woosa has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Woosa (integration-marktplaats-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/integration-marktplaats-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/integration-marktplaats-for-woocommerce"><img src="https://laskyr.com/plugins/integration-marktplaats-for-woocommerce/badge.svg" alt="Woosa vulnerability status"></a>