Skip to content
Laskyr

Plugins · integrate-dynamics-365-crm · data as of 2026-11-04

Is Integrate Dynamics 365 CRM safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.2 or newer fixes all of them that state a fix.

Latest version
1.2.1
Last updated
2026-10-28
Active installs
80+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Sync form data to create leads, contacts in Dynamics 365. Bi-directional sync WooCommerce orders, products, refunds with Dynamics 365 CRM & Busine … — by miniOrange

What to do

  1. Update to the latest version (1.2.1). Anything older than 1.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get integrate-dynamics-365-crm --field=version shows what you run; wp plugin update integrate-dynamics-365-crm updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-0725 · published 2026-01-17

Stored cross-site scripting (XSS) in Integrate Dynamics 365 CRM (1.1.1 and older)

Affected
1.1.1 and older
Fixed in
1.1.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Integrate Dynamics 365 CRM plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.1.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0725Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-10746 · published 2025-10-04

Missing authorization check in Integrate Dynamics 365 CRM (1.0.9 and older)

Affected
1.0.9 and older
Fixed in
1.1.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Integrate Dynamics 365 CRM plugin for WordPress is vulnerable to unauthorized access in all versions up to, and including, 1.0.9. This is due to missing capability checks and nonce verification on functions hooked to 'init'. This makes it possible for unauthenticated attackers to deactivate the plugin, tamper with OAuth configuration, and trigger test connections that expose sensitive data via direct request to vulnerable endpoints granted they can craft malicious requests with specific parameters.

NVD CVE-2025-10746Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Integrate Dynamics 365 CRM vulnerability status badge
<a href="https://laskyr.com/plugins/integrate-dynamics-365-crm"><img src="https://laskyr.com/plugins/integrate-dynamics-365-crm/badge.svg" alt="Integrate Dynamics 365 CRM vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit