Skip to content
Laskyr

Plugins · instapage · data as of 2026-11-04

Is Instapage Plugin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7.3)

As of 2026-11-04. 2 issues are on record for older versions; version 3.7.3 or newer fixes all of them that state a fix.

Latest version
3.7.3
Last updated
2026-10-12
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.4.0+

Instapage plugin - the best way for WordPress to seamlessly publish landing pages as a natural extension of your WordPress blog or website. — by instapagedev

What to do

  1. Update to the latest version (3.7.3). Anything older than 3.7.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get instapage --field=version shows what you run; wp plugin update instapage updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-39728 · published 2026-10-06

Server-side request forgery (SSRF) in Instapage Plugin (3.7.2 and older)

Affected
3.7.2 and older
Fixed in
3.7.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Server Side Request Forgery (SSRF) in Instapage Plugin <= 3.7.2 versions.

NVD CVE-2026-39728Patchstack advisory

medium 4.3 CVE-2025-60115 · published 2025-09-26

Cross-site request forgery (CSRF) in Instapage Plugin (3.7.0 and older)

Affected
3.7.0 and older
Fixed in
3.7.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in instapagedev Instapage Plugin instapage allows Cross Site Request Forgery.This issue affects Instapage Plugin: from n/a through <= 3.7.0.

NVD CVE-2025-60115Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Instapage Plugin vulnerability status badge
<a href="https://laskyr.com/plugins/instapage"><img src="https://laskyr.com/plugins/instapage/badge.svg" alt="Instapage Plugin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit