Skip to content
Laskyr

Plugins · instantsearch-for-woocommerce · data as of 2026-11-04

Is Search, Filters & Merchandising for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.75)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.68 or newer fixes all of them that state a fix.

Latest version
3.0.75
Last updated
2026-10-12
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Maximize your store sales with this easy-to-install plugin. Give shoppers a well-designed advanced search bar with live search suggestions. — by Fast Simon

What to do

  1. Update to the latest version (3.0.75). Anything older than 3.0.68 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get instantsearch-for-woocommerce --field=version shows what you run; wp plugin update instantsearch-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-12091 · published 2025-12-06

Missing authorization check in Search, Filters & Merchandising for WooCommerce (3.0.67 and older)

Affected
3.0.67 and older
Fixed in
3.0.68 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Search, Filters & Merchandising for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'wcis_save_email' endpoint in all versions up to, and including, 3.0.67. This makes it possible for authenticated attackers, with Subscriber-level access and above, to deactivate the plugin.

NVD CVE-2025-12091Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-32181 · published 2025-04-04

Stored cross-site scripting (XSS) in Search, Filters & Merchandising for WooCommerce (3.0.58 and older)

Affected
3.0.58 and older
Fixed in
3.0.59
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fast Simon Search, Filters & Merchandising for WooCommerce instantsearch-for-woocommerce allows Stored XSS.This issue affects Search, Filters & Merchandising for WooCommerce: from n/a through <= 3.0.58.

NVD CVE-2025-32181Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Search, Filters & Merchandising for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/instantsearch-for-woocommerce"><img src="https://laskyr.com/plugins/instantsearch-for-woocommerce/badge.svg" alt="Search, Filters & Merchandising for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit