Plugins · instagram-slider-widget · data as of 2026-11-04
Is Social Slider Feed safe? Known vulnerabilities and latest version
- Latest version
- 2.3.8
- Last updated
- 2026-10-15
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Display Instagram, Facebook and YouTube feeds in widgets, posts, pages, or anywhere else on your website. — by Themeisle
What to do
- Update to the latest version (2.3.8). Anything older than 2.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get instagram-slider-widget --field=version shows what you run; wp plugin update instagram-slider-widget updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-39507 · published 2026-06-15
Cross-site scripting (XSS) in Social Slider Feed (2.3.2 and older)
- Affected
- 2.3.2 and older
- Fixed in
- 2.3.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Social Slider Feed <= 2.3.2 versions.
medium 4.8 CVE-2024-10149 · published 2025-05-15
Stored cross-site scripting (XSS) in Social Slider Feed (older than 2.2.9)
- Affected
- older than 2.2.9
- Fixed in
- 2.2.9
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Social Slider Feed WordPress plugin before 2.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
low 3.5 CVE-2025-0717 · published 2025-03-25
Cross-site scripting (XSS) in Social Slider Feed (older than 2.2.9)
- Affected
- older than 2.2.9
- Fixed in
- 2.2.9
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
To exploit the vulnerability, it is necessary:
medium 4.3 CVE-2024-43215 · published 2024-11-01
Missing authorization check in Social Slider Feed (2.2.2 and older)
- Affected
- 2.2.2 and older
- Fixed in
- 2.2.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in creativemotion Social Slider Feed allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Social Slider Feed: from n/a through 2.2.2.
Recent activity
- 2026-10-15 — latest release on wordpress.org (2.3.8).
- 2026-06-15 — Cross-site scripting (XSS) disclosed (CVE-2026-39507), fixed in 2.3.3.
- 2025-05-15 — Stored cross-site scripting (XSS) disclosed (CVE-2024-10149), fixed in 2.2.9.
- 2025-03-25 — Cross-site scripting (XSS) disclosed (CVE-2025-0717), fixed in 2.2.9.
Get an email when Social Slider Feed has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Social Slider Feed (instagram-slider-widget) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Themeisle (18 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/instagram-slider-widget (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/instagram-slider-widget"><img src="https://laskyr.com/plugins/instagram-slider-widget/badge.svg" alt="Social Slider Feed vulnerability status"></a>