Skip to content
Laskyr

Plugins · instagram-feed · data as of 2026-11-01

Is Smash Balloon Social Photo Feed safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.15.0)

As of 2026-11-01. 3 issues are on record for older versions; version 6.11.4 or newer fixes all of them that state a fix.

Latest version
6.15.0
Last updated
2026-10-28
Active installs
1+ million
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Formerly "Instagram Feed". Display clean, customizable, and responsive Instagram feeds from multiple accounts. Supports Instagram oEmbeds. — by Syed Balkhi

What to do

  1. Update to the latest version (6.15.0). Anything older than 6.11.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get instagram-feed --field=version shows what you run; wp plugin update instagram-feed updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.7 CVE-2026-15452 · published 2026-08-05

Reflected cross-site scripting (XSS) in Smash Balloon Social Photo Feed (6.11.3 and older)

Affected
6.11.3 and older
Fixed in
6.11.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smash Balloon Social Photo Feed – Easy Social Feeds Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via REQUEST_URI Query String in all versions up to, and including, 6.11.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2026-15452Wordfence advisoryCode change (fix)Plugin source

medium 4.7 CVE-2026-12002 · published 2026-07-08

Cross-site request forgery (CSRF) in Smash Balloon Social Photo Feed (6.11.1 and older)

Affected
6.11.1 and older
Fixed in
6.11.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smash Balloon Social Photo Feed – Easy Social Feeds Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 6.11.1. This is due to missing or incorrect nonce validation on the maybe_connection_data function. This makes it possible for unauthenticated attackers to overwrite the site's Instagram and Facebook oEmbed access tokens via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-12002Wordfence advisoryCode change (fix)

medium 5.4 CVE-2025-4583 · published 2025-05-29

Stored cross-site scripting (XSS) in Smash Balloon Social Photo Feed (6.9.0 and older)

Affected
6.9.0 and older
Fixed in
6.9.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smash Balloon Social Photo Feed – Easy Social Feeds Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `data-plugin` attribute in all versions up to, and including, 6.9.0 (Free) and 6.8.0 (Pro) due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-4583Wordfence advisoryPlugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smash Balloon Social Photo Feed vulnerability status badge
<a href="https://laskyr.com/plugins/instagram-feed"><img src="https://laskyr.com/plugins/instagram-feed/badge.svg" alt="Smash Balloon Social Photo Feed vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit