Skip to content
Laskyr

Plugins · insert-pages · data as of 2026-11-04

Is Insert Pages safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.11.5)

As of 2026-11-04. 5 issues are on record for older versions; version 3.11.5 or newer fixes all of them that state a fix.

Latest version
3.11.5
Last updated
2026-06-19
Active installs
30,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8

Insert Pages lets you embed any WordPress content (e.g., pages, posts, custom post types) into other WordPress content using the Shortcode API. — by Paul Ryan

What to do

  1. Update to the latest version (3.11.5). Anything older than 3.11.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get insert-pages --field=version shows what you run; wp plugin update insert-pages updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-10089 · published 2026-07-02

Stored cross-site scripting (XSS) in Insert Pages (3.11.4 and older)

Affected
3.11.4 and older
Fixed in
3.11.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Insert Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via post custom field keys (meta key names) in all versions up to, and including, 3.11.4. This is due to insufficient output escaping in the the_meta() function: while the custom field VALUE is sanitized with wp_kses_post(), the custom field KEY ($key) is interpolated into the rendered HTML (lines 1786-1791) and echoed (line 1806) without any escaping when an inserted page is rendered with the [insert page='ID' display='all'] shortcode. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-10089Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2022-4483 · published 2023-01-16

Stored cross-site scripting (XSS) in Insert Pages (older than 3.7.5)

Affected
older than 3.7.5
Fixed in
3.7.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Insert Pages WordPress plugin before 3.7.5 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

NVD CVE-2022-4483WPScan advisory

medium 4.3 CVE-2021-24851 · published 2021-11-17

Missing authorization check in Insert Pages (older than 3.7.0)

Affected
older than 3.7.0
Fixed in
3.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD
Details from the advisory

The Insert Pages WordPress plugin before 3.7.0 allows users with a role as low as Contributor to access content and metadata from arbitrary posts/pages regardless of their author and status (ie private), using a shortcode. Password protected posts/pages are not affected by such issue.

NVD CVE-2021-24851WPScan advisoryCode change (fix)

medium 5.4 CVE-2021-24850 · published 2021-11-17

Cross-site scripting (XSS) in Insert Pages (older than 3.7.0)

Affected
older than 3.7.0
Fixed in
3.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Insert Pages WordPress plugin before 3.7.0 adds a shortcode that prints out other pages' content and custom fields. It can be used by users with a role as low as Contributor to perform Cross-Site Scripting attacks by storing the payload/s in another post's custom fields.

NVD CVE-2021-24850WPScan advisory

critical 9.1 CVE-2017-18586 · published 2019-08-22

Path traversal / file read in Insert Pages (older than 3.2.4)

Affected
older than 3.2.4
Fixed in
3.2.4
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The insert-pages plugin before 3.2.4 for WordPress has directory traversal via custom template paths.

NVD CVE-2017-18586wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Insert Pages vulnerability status badge
<a href="https://laskyr.com/plugins/insert-pages"><img src="https://laskyr.com/plugins/insert-pages/badge.svg" alt="Insert Pages vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit