Skip to content
Laskyr

Plugins · insert-headers-and-footers-script · data as of 2026-11-04

Is Insert Headers and Footers Code safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.10)

As of 2026-11-04. 3 issues are on record for older versions; version 1.1.9 or newer fixes all of them that state a fix.

Latest version
1.1.10
Last updated
2026-08-25
Active installs
7,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

This plugin allows you to insert Google analytic code, Facebook pixel code, custom javascript, custom style in your website's header and footer. — by HT Plugins

What to do

  1. Update to the latest version (1.1.10). Anything older than 1.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get insert-headers-and-footers-script --field=version shows what you run; wp plugin update insert-headers-and-footers-script updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-66474 · published 2026-07-27

Cross-site request forgery (CSRF) in Insert Headers and Footers Code (1.1.8 and older)

Affected
1.1.8 and older
Fixed in
1.1.9 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Insert Headers and Footers Code – HT Script <= 1.1.8 versions.

NVD CVE-2026-66474Patchstack advisory

medium 6.4 CVE-2025-12112 · published 2025-11-08

Stored cross-site scripting (XSS) in Insert Headers and Footers Code (1.1.6 and older)

Affected
1.1.6 and older
Fixed in
1.1.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Insert Headers and Footers Code – HT Script plugin for WordPress is vulnerable to Stored Cross-Site Scripting via adding scripts in all versions up to, and including, 1.1.6 due to insufficient capability checks. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-12112Wordfence advisoryCode change (fix)

medium 6.5 CVE-2025-2779 · published 2025-04-02

Missing authorization check in Insert Headers and Footers Code (1.1.2 and older)

Affected
1.1.2 and older
Fixed in
1.1.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Insert Headers and Footers Code – HT Script plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_dismiss function in all versions up to, and including, 1.1.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update option values to 1/true on the WordPress site. This can be leveraged to update an option that would create an error on the site and deny access to legitimate users or be used to set some values to true, such as registration.

NVD CVE-2025-2779Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Insert Headers and Footers Code vulnerability status badge
<a href="https://laskyr.com/plugins/insert-headers-and-footers-script"><img src="https://laskyr.com/plugins/insert-headers-and-footers-script/badge.svg" alt="Insert Headers and Footers Code vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit