Skip to content
Laskyr

Plugins · insert-headers-and-footers · data as of 2026-11-01

Is WPCode safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.1)

As of 2026-11-01. 1 issue is on record for older versions; version 2.3.6 or newer fixes all of them that state a fix.

Latest version
2.4.1
Last updated
2026-10-29
Active installs
3+ million
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Easily add code snippets in WordPress. Insert header & footer scripts, add PHP code snippets with conditional logic, insert ads pixel code, and more. — by Syed Balkhi

What to do

  1. Update to the latest version (2.4.1). Anything older than 2.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get insert-headers-and-footers --field=version shows what you run; wp plugin update insert-headers-and-footers updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-8832 · published 2026-05-27

Remote code execution in WPCode (2.3.5 and older)

Affected
2.3.5 and older
Fixed in
2.3.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPCode - Insert Headers and Footers + Custom Code Snippets - WordPress Code Manager plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 2.3.5 This is due to the 'wpcode' custom post type being registered without a custom capability_type or capability restrictions in the wpcode_register_post_type() function, allowing WordPress core to fall back to standard post capabilities for all creation paths including XML-RPC. This makes it possible for authenticated attackers, with author-level access and above, to create and publish executable PHP snippet posts via XML-RPC wp.newPost, which are then executed server-side via eval() in the run_eval() function when the snippet is rendered through the [wpcode] shortcode.

NVD CVE-2026-8832Wordfence advisoryCode change (fix)Plugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPCode vulnerability status badge
<a href="https://laskyr.com/plugins/insert-headers-and-footers"><img src="https://laskyr.com/plugins/insert-headers-and-footers/badge.svg" alt="WPCode vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit