Plugins · injection-guard · data as of 2026-11-04
Is Injection Guard safe? Known vulnerabilities and latest version
- Latest version
- 1.4.0
- Last updated
- 2026-10-31
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Blocks malicious and unknown query-string requests, detects injection attempts, and audits user capabilities and sessions. — by Fahad Mahmood
What to do
- Update to the latest version (1.4.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get injection-guard --field=version shows what you run; wp plugin update injection-guard updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-3368 · published 2026-03-21
Stored cross-site scripting (XSS) in Injection Guard (1.2.9 and older)
- Affected
- 1.2.9 and older
- Fixed in
- 1.3.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Injection Guard plugin for WordPress is vulnerable to Stored Cross-Site Scripting via malicious query parameter names in all versions up to and including 1.2.9. This is due to insufficient input sanitization in the sanitize_ig_data() function which only sanitizes array values but not array keys, combined with missing output escaping in the ig_settings.php template where stored parameter keys are echoed directly into HTML. When a request is made to the site, the plugin captures the query string via $_SERVER['QUERY_STRING'], applies esc_url_raw() (which preserves URL-encoded special characters like %22, %3E, %3C), then passes it to parse_str() which URL-decodes the string, resulting in decoded HTML/JavaScript in the array keys. These keys are stored via update_option('ig_requests_log') and later rendered without esc_html() or esc_attr() on the admin log page. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in the admin log page that execute whenever an administrator views the Injection Guard log interface.
NVD CVE-2026-3368Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2025-8046 · published 2025-08-14
Reflected cross-site scripting (XSS) in Injection Guard (older than 1.2.8)
- Affected
- older than 1.2.8
- Fixed in
- 1.2.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Injection Guard WordPress plugin before 1.2.8 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
medium 4.3 CVE-2023-32574 · published 2024-12-13
Missing authorization check in Injection Guard (1.2.1 and older)
- Affected
- 1.2.1 and older
- Fixed in
- 1.2.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Fahad Mahmood Injection Guard allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Injection Guard: from n/a through 1.2.1.
Recent activity
- 2026-10-31 — latest release on wordpress.org (1.4.0).
- 2026-03-21 — Stored cross-site scripting (XSS) disclosed (CVE-2026-3368), fixed in 1.3.0.
- 2025-08-14 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-8046), fixed in 1.2.8.
- 2024-12-13 — Missing authorization check disclosed (CVE-2023-32574), fixed in 1.2.2.
Get an email when Injection Guard has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Injection Guard (injection-guard) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Fahad Mahmood (9 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/injection-guard (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/injection-guard"><img src="https://laskyr.com/plugins/injection-guard/badge.svg" alt="Injection Guard vulnerability status"></a>