Skip to content
Laskyr

Plugins · infomaniak-connect-openid · data as of 2026-11-04

Is Infomaniak Connect for OpenID safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.5)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.4 or newer fixes all of them that state a fix.

Latest version
1.0.5
Last updated
2026-08-19
Active installs
30+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 8.0+

The Infomaniak Connect for OpenID plugin allows easy integration of OAuth2 authentication with Infomaniak into your WordPress site. — by Infomaniak

What to do

  1. Update to the latest version (1.0.5). Anything older than 1.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get infomaniak-connect-openid --field=version shows what you run; wp plugin update infomaniak-connect-openid updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1824 · published 2026-03-07

Stored cross-site scripting (XSS) in Infomaniak Connect for OpenID (1.0.2 and older)

Affected
1.0.2 and older
Fixed in
1.0.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Infomaniak Connect for OpenID plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'endpoint_login' parameter of the infomaniak_connect_generic_auth_url shortcode in all versions up to, and including, 1.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1824Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Infomaniak Connect for OpenID vulnerability status badge
<a href="https://laskyr.com/plugins/infomaniak-connect-openid"><img src="https://laskyr.com/plugins/infomaniak-connect-openid/badge.svg" alt="Infomaniak Connect for OpenID vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit