Plugins · info-cards · data as of 2026-11-04
Is Info Cards safe? Known vulnerabilities and latest version
- Latest version
- 3.0.4
- Last updated
- 2026-11-01
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Simple and easy way to create and display information cards anywhere . — by bPlugins
What to do
- Update to the latest version (3.0.4). Anything older than 2.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get info-cards --field=version shows what you run; wp plugin update info-cards updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-4120 · published 2026-03-19
Stored cross-site scripting (XSS) in Info Cards (2.0.7 and older)
- Affected
- 2.0.7 and older
- Fixed in
- 2.0.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Info Cards – Add Text and Media in Card Layouts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'btnUrl' parameter within the Info Cards block in all versions up to, and including, 2.0.7. This is due to insufficient input validation on URL schemes, specifically the lack of javascript: protocol filtering. The block's render.php passes all attributes as JSON to the frontend via a data-attributes HTML attribute using esc_attr(wp_json_encode()), which prevents HTML attribute injection but does not validate URL protocols within the JSON data. The client-side view.js then renders the btnUrl value directly as an href attribute on anchor elements without any protocol sanitization. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject javascript: URLs that execute arbitrary web scripts when a user clicks the rendered button link.
high 7.1 CVE-2025-54711 · published 2025-11-06
Missing authorization check in Info Cards (1.0.11 and older)
- Affected
- 1.0.11 and older
- Fixed in
- 2.0.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in bPlugins Info Cards info-cards allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Info Cards: from n/a through <= 1.0.11.
medium 6.5 CVE-2025-26945 · published 2025-02-25
Stored cross-site scripting (XSS) in Info Cards (1.0.5 and older)
- Affected
- 1.0.5 and older
- Fixed in
- 1.0.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Info Cards info-cards allows Stored XSS.This issue affects Info Cards: from n/a through <= 1.0.5.
Recent activity
- 2026-11-01 — latest release on wordpress.org (3.0.4).
- 2026-03-19 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4120), fixed in 2.0.8.
- 2025-11-06 — Missing authorization check disclosed (CVE-2025-54711), fixed in 2.0.0.
- 2025-02-25 — Stored cross-site scripting (XSS) disclosed (CVE-2025-26945), fixed in 1.0.6.
Get an email when Info Cards has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Info Cards (info-cards) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bPlugins (36 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/info-cards (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/info-cards"><img src="https://laskyr.com/plugins/info-cards/badge.svg" alt="Info Cards vulnerability status"></a>