Plugins · inext-woo-pincode-checker · data as of 2026-11-04
Is iNext Woo Pincode Checker safe? Known vulnerabilities and latest version
- Latest version
- 2.4
- Last updated
- 2026-08-05
- Active installs
- 600+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Let customers check delivery availability by PIN, ZIP or postal code using WooCommerce Shipping Zones with fast AJAX validation. — by Imdad Next Web
What to do
- Update to the latest version (2.4). Anything older than 2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get inext-woo-pincode-checker --field=version shows what you run; wp plugin update inext-woo-pincode-checker updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-62084 · published 2025-12-31
Cross-site request forgery (CSRF) in iNext Woo Pincode Checker (2.3.1 and older)
- Affected
- 2.3.1 and older
- Fixed in
- 2.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Imdad Next Web iNext Woo Pincode Checker inext-woo-pincode-checker allows Cross Site Request Forgery.This issue affects iNext Woo Pincode Checker: from n/a through <= 2.3.1.
Recent activity
- 2026-08-05 — latest release on wordpress.org (2.4).
- 2025-12-31 — Cross-site request forgery (CSRF) disclosed (CVE-2025-62084), fixed in 2.4.
Get an email when iNext Woo Pincode Checker has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for iNext Woo Pincode Checker (inext-woo-pincode-checker) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/inext-woo-pincode-checker (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/inext-woo-pincode-checker"><img src="https://laskyr.com/plugins/inext-woo-pincode-checker/badge.svg" alt="iNext Woo Pincode Checker vulnerability status"></a>