Plugins · independent-analytics · data as of 2026-11-04
Is Independent Analytics safe? Known vulnerabilities and latest version
- Latest version
- 2.16.2
- Last updated
- 2026-10-22
- Active installs
- 100,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0.30+
A simple, yet powerful WordPress analytics plugin that gives you privacy-friendly stats to grow your website. A Google Analytics alternative. — by Ben Sibley
What to do
- Update to the latest version (2.16.2). Anything older than 2.15.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get independent-analytics --field=version shows what you run; wp plugin update independent-analytics updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-17506 · published 2026-08-05
Stored cross-site scripting (XSS) in Independent Analytics (2.15.0 and older)
- Affected
- 2.15.0 and older
- Fixed in
- 2.15.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Independent Analytics plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 404 not_found_url tracking parameter in versions up to, and including, 2.15.0. This is due to the get_cell_content() function applying urldecode() after esc_url() when rendering the URL column for 404 entries — a sequence that allows percent-encoded HTML to pass URL validation and then be reconstructed as raw markup, which wp_kses_post() does not strip because it retains img elements and data-* attributes, and because the public REST endpoint /iawp/search accepts unauthenticated requests as long as they carry a signature that is itself embedded in public page HTML. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-17506Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-5737 · published 2026-05-28
Server-side request forgery (SSRF) in Independent Analytics (2.14.9 and older)
- Affected
- 2.14.9 and older
- Fixed in
- 2.14.10 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Independent Analytics plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.14.9. This is due to a public tracking route at /wp-json/iawp/search that accepts attacker-controlled referrer_url values when the signature matches, combined with a scheduled favicon fetcher that performs unrestricted cURL requests to stored domains. The signature validation is insufficient because the signature is embedded in publicly-accessible JavaScript and the salt is static per site, allowing attackers to extract valid signatures. The favicon downloader uses raw cURL functions without any SSRF protection mechanisms (no localhost blocking, no private network filtering, and does not use WordPress's wp_safe_remote_* functions). This makes it possible for unauthenticated attackers to inject malicious referrer domains into the database and trigger server-side requests to arbitrary hosts including internal services.
NVD CVE-2026-5737Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-22 — latest release on wordpress.org (2.16.2).
- 2026-08-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-17506), fixed in 2.15.1.
- 2026-05-28 — Server-side request forgery (SSRF) disclosed (CVE-2026-5737), fixed in 2.14.10.
Get an email when Independent Analytics has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Independent Analytics (independent-analytics) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/independent-analytics (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/independent-analytics"><img src="https://laskyr.com/plugins/independent-analytics/badge.svg" alt="Independent Analytics vulnerability status"></a>