Skip to content
Laskyr

Plugins · immonex-kickstart · data as of 2026-11-04

Is immonex Kickstart safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.18.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.13.4 or newer fixes all of them that state a fix.

Latest version
1.18.0
Last updated
2026-09-24
Active installs
300+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.2 · PHP 8.1+

Essential components and add-on framework for embedding and searching/filtering imported OpenImmo-XML-based real estate offers — by immonex

What to do

  1. Update to the latest version (1.18.0). Anything older than 1.13.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get immonex-kickstart --field=version shows what you run; wp plugin update immonex-kickstart updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-31918 · published 2026-03-13

Stored cross-site scripting (XSS) in immonex Kickstart (1.13.0 and older)

Affected
1.13.0 and older
Fixed in
1.13.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in immonex immonex Kickstart immonex-kickstart allows Stored XSS.This issue affects immonex Kickstart: from n/a through <= 1.13.0.

NVD CVE-2026-31918Patchstack advisory

high 7.5 CVE-2025-58637 · published 2025-09-03

File inclusion in immonex Kickstart (1.11.6 and older)

Affected
1.11.6 and older
Fixed in
1.11.13
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in immonex immonex Kickstart immonex-kickstart allows PHP Local File Inclusion.This issue affects immonex Kickstart: from n/a through <= 1.11.6.

NVD CVE-2025-58637Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
immonex Kickstart vulnerability status badge
<a href="https://laskyr.com/plugins/immonex-kickstart"><img src="https://laskyr.com/plugins/immonex-kickstart/badge.svg" alt="immonex Kickstart vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit