Skip to content
Laskyr

Plugins · imgspider · data as of 2026-11-04

Is IMGspider safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.0)

As of 2026-11-04. 3 issues are on record for older versions; version 2.4.0 or newer fixes all of them that state a fix.

Latest version
2.5.0
Last updated
2026-09-05
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

IMGspider(图片蜘蛛)是一款用于WordPress文章图片抓取的WordPress插件,支持JPG, JPEG, PNG, GIF, BMP, TIF, WebP, AVIF等常见图片爬取下载,实现一键抓取文章内容所有引用图片到本地服务器。 Pro版本是在原有的IMGspider图片采集插件 … — by wbolt.com

What to do

  1. Update to the latest version (2.5.0). Anything older than 2.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get imgspider --field=version shows what you run; wp plugin update imgspider updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-22482 · published 2026-01-22

Server-side request forgery (SSRF) in IMGspider (2.3.12 and older)

Affected
2.3.12 and older
Fixed in
2.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in wbolt.com IMGspider imgspider allows Server Side Request Forgery.This issue affects IMGspider: from n/a through <= 2.3.12.

NVD CVE-2026-22482Patchstack advisory

high 8.8 CVE-2024-6319 · published 2024-07-04

Arbitrary file upload in IMGspider (2.3.10 and older)

Affected
2.3.10 and older
Fixed in
2.3.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The IMGspider plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'upload' function in all versions up to, and including, 2.3.10. This makes it possible for authenticated attackers, with contributor-level and above permissions, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2024-6319Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-6318 · published 2024-07-04

Arbitrary file upload in IMGspider (2.3.10 and older)

Affected
2.3.10 and older
Fixed in
2.3.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The IMGspider plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'upload_img_file' function in all versions up to, and including, 2.3.10. This makes it possible for authenticated attackers, with contributor-level and above permissions, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2024-6318Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
IMGspider vulnerability status badge
<a href="https://laskyr.com/plugins/imgspider"><img src="https://laskyr.com/plugins/imgspider/badge.svg" alt="IMGspider vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit