Skip to content
Laskyr

Plugins · image-widget · data as of 2026-11-04

Is Image Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.12)

As of 2026-11-04. 2 issues are on record for older versions; version 4.4.12 or newer fixes all of them that state a fix.

Latest version
4.4.12
Last updated
2026-04-20
Active installs
100,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.7.11

A simple image widget that uses the native WordPress media manager to add image widgets to your site. — by Nexcess

What to do

  1. Update to the latest version (4.4.12). Anything older than 4.4.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get image-widget --field=version shows what you run; wp plugin update image-widget updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-42643 · published 2026-04-29

Stored cross-site scripting (XSS) in Image Widget (4.4.11 and older)

Affected
4.4.11 and older
Fixed in
4.4.12
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in StellarWP Image Widget image-widget allows Stored XSS.This issue affects Image Widget: from n/a through <= 4.4.11.

NVD CVE-2026-42643Patchstack advisory

medium 4.8 CVE-2024-10939 · published 2024-12-13

Stored cross-site scripting (XSS) in Image Widget (older than 4.4.11)

Affected
older than 4.4.11
Fixed in
4.4.11
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Image Widget WordPress plugin before 4.4.11 does not sanitise and escape some of its Image Widget settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-10939WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Image Widget vulnerability status badge
<a href="https://laskyr.com/plugins/image-widget"><img src="https://laskyr.com/plugins/image-widget/badge.svg" alt="Image Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit