Skip to content
Laskyr

Plugins · image-viewer · data as of 2026-11-04

Is All In One Image Viewer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.3 or newer fixes all of them that state a fix.

Latest version
1.1.1
Last updated
2026-11-04
Active installs
300+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A free Gutenberg block to display images with zoom, magnify, clickable image maps, and 360° panorama rotation. — by bPlugins

What to do

  1. Update to the latest version (1.1.1). Anything older than 1.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get image-viewer --field=version shows what you run; wp plugin update image-viewer updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-1294 · published 2026-02-05

Server-side request forgery (SSRF) in All In One Image Viewer (1.0.2 and older)

Affected
1.0.2 and older
Fixed in
1.0.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The All In One Image Viewer Block plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.0.2 due to missing authorization and URL validation on the image-proxy REST API endpoint. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2026-1294Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
All In One Image Viewer vulnerability status badge
<a href="https://laskyr.com/plugins/image-viewer"><img src="https://laskyr.com/plugins/image-viewer/badge.svg" alt="All In One Image Viewer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit