Skip to content
Laskyr

Plugins · image-source-control-isc · data as of 2026-11-04

Is Image Source Control Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.12.0)

As of 2026-11-04. 4 issues are on record for older versions; version 3.9.2 or newer fixes all of them that state a fix.

Latest version
3.12.0
Last updated
2026-08-26
Active installs
3,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Show image credits, image captions, and copyrights. Manage image sources, licenses and AI label. The original plugin since 2012. — by Thomas Maier

What to do

  1. Update to the latest version (3.12.0). Anything older than 3.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get image-source-control-isc --field=version shows what you run; wp plugin update image-source-control-isc updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4852 · published 2026-04-20

Stored cross-site scripting (XSS) in Image Source Control Lite (3.9.1 and older)

Affected
3.9.1 and older
Fixed in
3.9.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Image Source Control Lite – Show Image Credits and Captions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Image Source' attachment field in all versions up to, and including, 3.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4852Wordfence advisoryPlugin source

high 7.1 CVE-2025-22711 · published 2025-01-21

Reflected cross-site scripting (XSS) in Image Source Control Lite (2.29.0 and older)

Affected
2.29.0 and older
Fixed in
2.29.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Thomas Maier Image Source Control image-source-control-isc allows Reflected XSS.This issue affects Image Source Control: from n/a through <= 2.29.0.

NVD CVE-2025-22711Patchstack advisory

medium 6.1 CVE-2024-13515 · published 2025-01-18

Reflected cross-site scripting (XSS) in Image Source Control Lite (2.28.0 and older)

Affected
2.28.0 and older
Fixed in
2.28.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Image Source Control Lite – Show Image Credits and Captions plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'path' parameter in all versions up to, and including, 2.28.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-13515Wordfence advisoryCode change (fix)github.com

high 7.5 CVE-2023-52187 · published 2024-01-27

Information disclosure in Image Source Control Lite (2.17.0 and older)

Affected
2.17.0 and older
Fixed in
2.17.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Thomas Maier Image Source Control Lite – Show Image Credits and Captions.This issue affects Image Source Control Lite – Show Image Credits and Captions: from n/a through 2.17.0.

NVD CVE-2023-52187Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Image Source Control Lite vulnerability status badge
<a href="https://laskyr.com/plugins/image-source-control-isc"><img src="https://laskyr.com/plugins/image-source-control-isc/badge.svg" alt="Image Source Control Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit