Plugins · image-slider-widget · data as of 2026-11-04
Is Image Slider safe? Known vulnerabilities and latest version
- Latest version
- 1.1.130
- Last updated
- 2026-09-17
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 7.1.4
Image Slider - The best and very easy slider plugin for your post, page or sidebar. 100% Responsive. — by GhozyLab
What to do
- There is no fixed version yet. If you can live without Image Slider for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get image-slider-widget --field=version shows what you run; wp plugin update image-slider-widget updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 1.1.130 CVE-2026-42700 · published 2026-10-05
Stored cross-site scripting (XSS) in Image Slider (1.1.130 and older)
- Affected
- 1.1.130 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GhozyLab Image Slider Widget image-slider-widget allows Stored XSS.This issue affects Image Slider Widget: from n/a through 1.1.130.
medium 5.9 CVE-2024-32707 · published 2024-04-24
Stored cross-site scripting (XSS) in Image Slider (1.1.125 and older)
- Affected
- 1.1.125 and older
- Fixed in
- 1.1.127
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GhozyLab Image Slider Widget allows Stored XSS.This issue affects Image Slider Widget: from n/a through 1.1.125.
medium 4.3 CVE-2022-2223 · published 2022-07-18
Cross-site request forgery (CSRF) in Image Slider (1.1.121 and older)
- Affected
- 1.1.121 and older
- Fixed in
- 1.1.123 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WordPress plugin Image Slider is vulnerable to Cross-Site Request Forgery in versions up to, and including 1.1.121 due to failure to properly check for the existence of a nonce in the function ewic_duplicate_slider. This make it possible for unauthenticated attackers to duplicate existing posts or pages granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2022-2223Wordfence advisoryCode change (fix)Wordfence advisory
Recent activity
- 2026-09-17 — latest release on wordpress.org (1.1.130).
- 2026-10-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-42700), no fix listed yet.
- 2024-04-24 — Stored cross-site scripting (XSS) disclosed (CVE-2024-32707), fixed in 1.1.127.
- 2022-07-18 — Cross-site request forgery (CSRF) disclosed (CVE-2022-2223), fixed in 1.1.123.
Get an email when Image Slider has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Image Slider (image-slider-widget) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by GhozyLab (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/image-slider-widget (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/image-slider-widget"><img src="https://laskyr.com/plugins/image-slider-widget/badge.svg" alt="Image Slider vulnerability status"></a>