Plugins · image-hub · data as of 2026-11-04
Is Image Hub safe? Known vulnerabilities and latest version
- Latest version
- 1.3.0
- Last updated
- 2026-10-14
- Active installs
- 10,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Access and manage royalty-free images from Unsplash, Pixabay, Pexels, Openverse & Giphy without leaving your WordPress dashboard. — by Extend Themes
What to do
- Update to the latest version (1.3.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get image-hub --field=version shows what you run; wp plugin update image-hub updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-109191 · published 2026-10-16
Information disclosure in Image Hub (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.3.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Image Hub – Free Images from Unsplash, Pixabay, Pexels, Openverse & Giphy plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.2.0 via the 'image_hub_api_keys_* (6 options)' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract the plaintext API credentials for six third-party services — Giphy, Openverse (client ID and secret), Pexels, Pixabay, and Unsplash — emitted verbatim into every admin page's HTML via wp_localize_script. The leaked page HTML also contains a valid image_hub_nonce AJAX nonce, which — combined with the absence of any capability check in the image_hub_update_settings AJAX handler — allows the same Subscriber-level attacker to overwrite all six stored API credential options via update_option().
NVD CVE-2026-109191Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-14 — latest release on wordpress.org (1.3.0).
- 2026-10-16 — Information disclosure disclosed (CVE-2026-109191), fixed in 1.3.0.
Get an email when Image Hub has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Image Hub (image-hub) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Extend Themes (4 tracked)
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/image-hub (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/image-hub"><img src="https://laskyr.com/plugins/image-hub/badge.svg" alt="Image Hub vulnerability status"></a>